What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    After clicking Submit, submit is stuck on "Please wait...".

    Asked by emucoe on September 26, 2016 at 03:03 PM

    I see a number of other people have had this problem, but there doesn't seem to be one root cause.

    Our form is the "main form", as described in your Save form and continue later help info: https://www.jotform.com/help/97-How-to-Save-Forms-and-Continue-Later

    The form is not embedded anywhere yet. We are still testing. The direct link to the form is: https://form.jotform.com/62666148529971

    The form that feeds into the main form is: https://form.jotform.com/62686019801963

    This has been tried on different computers, with different browsers and different users.

    Page URL:
    https://form.jotform.com/62666148529971

    please wait stuck after clicking
  • Profile Image
    JotForm Support

    Answered by Jan on September 26, 2016 at 05:09 PM

    I cloned the main form and the first form. I did a test submission and it was successful. So I opened your form and did a test submission. It was successful as well. Here's the screenshot of the Thank You page:

     

    As you can see, I received the autoresponder for the 1st form, which is the one that are used for the Save and Return function.

    I also received the autoresponder email of the main form.

    I believe that you are experiencing this problem in the main form only. I would suggest the following:

    1. Remove and re-insert the Orderable List widget.

    2. Please add a username in the email field as a default. For example, youremail@emich.edu.

    3. Also, if you were able to replicate the issue on your end, please provide a screenshot of the browser console when this happens. In Google Chrome, you just need to press "ctrl + shift + J" and check if there are any errors.

    Hope this helps. Let us know if the issue persists. Thank you.

  • Profile Image
    JotForm Support

    Answered by EltonCris on October 03, 2016 at 08:51 AM

    This is now resolved. Our developers have just released a fix that should sort this out. It was mainly caused by the widgets in your form.

    Your forms should now be submitting normally. Kindly check and let us know if you see any other issues.