Calculation widget adding 0 after the calculated result

  • Profile Image
    howrenmusic
    Asked on September 28, 2016 at 05:06 PM

    I have embedded the "Perform Calculation Widget" in my form.  There is a "0" already sitting in the form where the calculation will go.  It is adding the "0" to to total.  If the calculation total is $14 it is making it $140.  Can someone help me with this?

    Thanks

     

  • Profile Image
    Kiran
    Answered on September 28, 2016 at 10:38 PM

    I have checked your JotForm and it seems to be working fine at my end.

    Were you able to fix the issue with the calculation? If the issue still persists at your end, please let us know.

    On a side note, I notice that your JotForm is collecting credit card and SSN information on plain text fields which is not allowed. Such forms are considered as phishing forms and associated accounts are automatically suspended. Please refer to our Terms of usage for more information on phishing. Please remove the guilty fields immediately from the JotForm to avoid suspension on your account.

    Thanks!

      

  • Profile Image
    howrenmusic
    Answered on September 29, 2016 at 10:26 AM

    Clearly, the addition did not work! The total is way off.   In this case, it did not add the zero, that happens more with instrument (clarinet) supplies that don't end with .50.  When you go to Clarinet Supplies, and choose anything that is an even number (mpc spray, practice stand, reeds) it adds a "0" to the price.  I have gone back and deleted them all and re-entered them all but it still persists.

    Julie Howren

    Howren Music

    704-525-5073

     

  • Profile Image
    Kiran
    Answered on September 29, 2016 at 12:34 PM

    If you are referring to the total to checked items in the screenshot, there are few more items that are checked on the form that are not included in the screenshot. However, I am able to replicate the issue with the Clarinet option in the accessories calculation field. This is being caused due to a Plus (+) sign is missing in the calculation formula of Accessories field.

    I also notice that there are several conditions are placed to insert the value of the option checked which will conflict with the formula in the calculation field.

    Please try disabling all these conditions to make sure that the calculation formula is working fine. You may also consider assigning calculation values to the checkbox fields that helps in accuracy of calculations.

    https://www.jotform.com/help/301-How-to-Assign-Calculation-Value

    Hope this information helps! 

    PS: The credit card fields are not yet removed from the form. Please note that the account will be disabled if these guilty fields are not removed from your JotForm.