What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Checkbox Option at end of form casuing form to get stuck on Please Wait

    Asked by nicolebreeden1 on September 29, 2016 at 10:56 AM

    2 clients have said it now and i tested it myself & it does the same. It works fine for 2 clients however...

    Page URL:
    https://form.jotformeu.com/61323266146350

    Screenshot
    please wait form will not submit how how many stuck on please wait won't submit form not loading
  • Profile Image
    JotForm Support

    Answered by KadeJM on September 29, 2016 at 01:12 PM

    I've tested this issue you are having with the form not submitting if "yes" (option 1) is ticked for your checkbox field at the end of your form but, it seems to be working normally on my end.

    Can you try it again now and let us know if this problem is still occurring? 

    If so may we have permission to test this further directly on your form? 

    Also, please let us know what browser you are using on your end?

  • Profile Image

    Answered by nicolebreeden1 on September 30, 2016 at 04:46 AM
    Hi,
    I see that you have chosen the option for 2 applicants which is not where
    the problem lies - I said it is only when 1 applicant is chosen that this
    problem occurs
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image

    Answered by nicolebreeden1 on September 30, 2016 at 04:46 AM
    It does this on chrome
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image
    JotForm Support

    Answered by Rose on September 30, 2016 at 09:07 AM

    Thank you for letting us know your issue.

    When I cloned and tested your form on my side, I realised that this issue have been happening due to logic errors on your conditions. Please give me some time to determine which conditions are need to be  configured again and how. Since, you have quite more conditions and this takes time. 

    Thanks for your understanding. 

  • Profile Image

    Answered by nicolebreeden1 on September 30, 2016 at 09:46 AM
    No problem,
    Thanks
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image
    JotForm Support

    Answered by Rose on September 30, 2016 at 10:04 AM

    Conditions need to be configured again mentioned here below 

    1.  Show/Hide condition for < How Many Applicants?> field. 

    - you need to create an if statement for selection of 1 applicant. This statement should be configured based on the idea of hide all the fields for client 2 on the form. 

    2.  Enable/Require field condition

    - you need to configure require field rules for both clients separately, not in the same condition. For example, lets look at following condition;



    This condition tells us that when client 1 field is filled as  <yes> for this if statement, it also make matrix field of client 2 required but this matrix field is hided. In other words,when you select 1 applicant and fill the mortgages field for client 1 as <Yes>, This makes matrix field of client 1 and client 2 required but client 2 fields are hided due to show/hide rule for selection 1 applicant. That's why, a conflict is happening and your form is stuck at please wait. 

    Please re-configure your condition carefully and let us know if the issue persist or if you need any further support by our side. 

  • Profile Image

    Answered by nicolebreeden1 on September 30, 2016 at 10:46 AM
    Hi rose,
    Could you please correct this for me?
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image

    Answered by nicolebreeden1 on September 30, 2016 at 11:46 AM
    I have deleted the conditions where I have required logic for both clients
    in 1 & I am still experiencing the same problems in chrome. Please can you
    amend the errors for me. you have my permission to go onto the form
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image
    JotForm Support

    Answered by Kiran on September 30, 2016 at 02:23 PM

    Rose is unavailable at the moment and I am checking the form conditions and the corrections provided by our colleague. Please allow me to check this up and get back to you.

    Thanks!

  • Profile Image

    Answered by nicolebreeden1 on October 03, 2016 at 06:45 AM
    Please can I have an update on this - the one applicant option is still not
    working in chrome
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on October 03, 2016 at 08:43 AM

    This is caused by the widgets in your form and our developers have just released a fix that should sort this issue.

    Your forms should now be submitting normally as usual. Kindly check.

  • Profile Image

    Answered by nicolebreeden1 on October 03, 2016 at 10:45 AM
    It is still occurring on chrome...
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...
  • Profile Image
    JotForm Support

    Answered by Kiran on October 03, 2016 at 12:22 PM

    I have tried submitting your JotForm using Chrome browser and was able to submit the form without any issue. The Thank you page is displayed normally.

    Please try opening the form in a private/incognito window and see you are able to submit the form. You may try force reloading the form by pressing Ctrl+F5. Let us know how it goes.

    Thanks!

  • Profile Image

    Answered by nicolebreeden1 on October 04, 2016 at 04:45 AM
    It is working now thank you
    *Nicole Breeden*
    Marketing Manager
    *0203 245 2862*
    Web: agent-tracker.co.uk
    Twitter: @agenttracker
    ...