Unable to open specific forms in form builder and getting errors when viewing the direct links

  • Profile Image
    sarahcons
    Asked on September 30, 2016 at 06:53 AM

    Unfortunately I am getting the error “502 Bad Gateway” “nginx/1.10.1” when trying to access the following forms:

     

     

     

    formID=32112405218945

     

    formID=32752015454954

     

    formID=62732416128352

     

    formID=62732340932351

     

     I received several complaints from customers already and I tried to access them from my PC and I get the same error. I can access them through Jotform, modify them and save etc. But if I click on the web links I get the aforementioned error.

     

     

    Could you please check what the problem is?

     

     

     

    Thank you

  • Profile Image
    Charlie
    Answered on September 30, 2016 at 11:33 AM

    Hi,

    I was able to replicate the problem by checking your account, I also tried to clone your forms but it actually crashed my browser. There seems to be a specific problem with your forms but I can't further check it because I can't open them in the form builder or even by using its form links.

    Some of your forms are actually working, I guess there's a setup or widget that is failing on those four forms. I will forward this to our developers to have it checked and fixed. Apologies for the inconvenience.

    Apologies for the inconvenience.

  • Profile Image
    sarahcons
    Answered on October 03, 2016 at 04:54 AM

    I do not use any particular widgets, only drop down menus and upload and submit ones. I checked the form and created clones as well. The error is replicated in the clones and the forms are too complex to recreate from scratch. The other forms that work are simple "contact us" type forms.

     

     

  • Profile Image
    sarahcons
    Answered on October 03, 2016 at 06:03 AM

    The problem seems to be the widget with the drop down menu containing about 4k entries and repeated several times in the form. At first I attempted to put all the entries in a single drop down menu, but after a while for some reason the system would cut down the last few thousand entries. For this reason I had to split the entries in two separate menus and it has worked for years. Could you please verify if deleting that widget the problem is solved for you as well? Unfortunately I can't really do without it though

  • Profile Image
    Irshad
    Answered on October 03, 2016 at 09:33 AM

    Thanks for providing further details. I also tried to check your Forms, but Browser got unresponsive, while trying to open those forms in Form builder.

    This issue is already assigned to our Development team, and we will send you further updates on this very soon.

    Thanks for your patience.

  • Profile Image
    NeilVicente
    Answered on April 22, 2017 at 06:01 PM

    @sarahcons

    We are reviewing past tickets and came across yours. 

    While we are able to recreate the issue on V3, JotForm has already released V4 and based on our tests, the forms work well on the latest JotForm version.

    Can you please confirm that you are able to work on your form without hiccups under V4?