Checklist Widget: Single tap does not select the item on iOS/Android

  • Profile Image
    Asked on October 01, 2016 at 02:31 PM

    I wrote about this a few days ago, and thought I found the solution. It turns out this problem persists. I replaced the checkbox I was using with the widget to handle my Terms and Conditions agreement place.

    I thought it was fine and it is on a desktop computer, but I just tested on an iPad with a couple of my forms and the same thing happens. I always get the message that the field is required, but when I check the box and press submit, the same error comes up as if I hadn't selected the checkbox at all! 

    Any ideas why this is happening only on devices? 

  • Profile Image
    Answered on October 01, 2016 at 09:59 PM

    Can you please share to us a screenshot image of the error you encounter on Ipad device browser.

    You can follow this user guide to include the image when you reply on this thread.


    I just test your form again on the Ipad device browser, but I cannot produce the error you report about the *required Checkbox widget (its actually a Checklist widget)


    I can turn ON/OFF the checkbox and it was properly recognized by the form on the submission script. Here is the video.

    We'll wait for your updated response.



  • Profile Image
    Answered on October 02, 2016 at 09:51 AM

    Well I can't take a screencast on my iPad. But I tool screenshots. First of the error message, then of me selecting the checkbox, then the same error message and an empty checkbox after I pressed submit.


  • Profile Image
    Answered on October 02, 2016 at 12:29 PM

    Base from your screenshots, apparently the selection on that widget didn't kick in or stick. That's what usually appears when on hover state. Or perhaps the touch event on that widget was not properly recognized.

    Please ensure that you have ticked the box properly. When the check mark looks a bit transparent, that means it is on hover state (not selected yet). When it's fully shady, that means it is selected. You can compare the image below.

    Not yet selected:


    I suggest using the regular checkbox field as your terms and agreement like the one you are currently using above that widget. This should work perfectly on any devices and browsers.

    Alternatively, you may want to consider the terms widget


  • Profile Image
    Answered on October 02, 2016 at 12:43 PM


    Thanks so much for your help with this! The reason I switched to the widget is because I was having an issue with the regular checkbox that was similar except that it wouldn't let the user select the box at all. I like how the widget styles this with a box around the field, and I don't relish changing it back on all my forms, so let's continue to explore this one.

    The terms and conditions widget, I think, only lets you like to a webpage. So that's not what I want either. I want the terms right in the form and not in the tiny hover. 

    I went back to my iPad and looked again. Sure enough, when I selected the box it then looked greyed out a bit as you described below. It's not just the way I select it - it's not user error. I know because 1) I'm not the only person having this issue and 2) the box went from empty to having a checkbox, so clearly I touched it in the right spot for it to do something. 

    When I selected the box a second time, it got darker and let me submit the form. Which is good, except there's no way our visitors are going to know or expect to have to click the box twice. When I click it a third time it goes back to hover state. Did you have to click it twice?

    I also tried holding my finger on the spot a tad longer. Pressing instead of "tapping" the spot. But the same thing happened. It goes into hover state and doesn't become properly selected unless you touch it twice. 

    Hopefully this feedback provides some clues towards a solution?

  • Profile Image
    Answered on October 02, 2016 at 04:16 PM

    What version of the iOS do you use on the iPad? Also, do you use the form by its direct link, or embedded form on some web page?

    A single tap on the Checklist widget item seems to be fine on my Android tablet, and iPad simulator via

  • Profile Image
    Answered on October 02, 2016 at 11:38 PM

    I have the most recent version that was just released. I think it became available a week or so ago. So I think it is OS 10.

    Since we are really just testing the forms right now...getting them ready, I access only the "preview" of the form. It is not embedded anywhere. So just direct link. 

  • Profile Image
    Answered on October 03, 2016 at 12:18 AM

    I was able to reproduce this problem even on Android. 

    I have now raised this to our developers for a resolution.

    You will be informed here once this is fixed.

    For now, you might also want to consider this You can add the terms directly on the box.


  • Profile Image
    Answered on October 03, 2016 at 11:51 AM

    Thank you for the confirmation of the issue and for taking it to the developers. 

    I just tried the widget, I don't think that's the one I tried before. But in the content, can I create HTML links? In our terms we have a couple of really important documents and pre-requisites and so we want to create links in a couple of places. So for example, they must already be a member. If they are not, we have a link to become one. Also, they are acknowledging that they have a reviewed a long Disclosures document, so we are including a link to that PDF. Is that possible with this widget?

  • Profile Image
    Answered on October 03, 2016 at 03:10 PM

    Yes, you can add the HTML links within Short Scrollable Terms widget's content area.


    Thank you.

  • Profile Image
    Answered on October 03, 2016 at 03:57 PM

    Oh good. Thank you!