If I made a custom link for my form, what is my form ID, where does it

  • Profile Image
    MedfordPhotography
    Asked on April 28, 2012 at 10:56 PM

    If I made a custom link for my form, what is my form ID, where does it start, etc...?



    This is a re-post of a comment on

  • Profile Image
    liyam
    Answered on April 29, 2012 at 04:41 AM

    The form ID is a long string of numbers generated by the system once you create your form here in JotForm.

    The form ID can be found when you preview your form, or when you embed your form to your own web page.  Find the long string of numbers in the address bar or the source URL of the javascript code:

     

    If you have other questions or concerns, please let us know.

    Thanks.

  • Profile Image
    MedfordPhotography
    Answered on April 30, 2012 at 06:56 PM

    I found the long string of numbers and followed all the instructions here to make a clickable edit link: http://www.jotform.com/help/96-How-to-Make-a-Clickable-Edit-Link. I clicked on Test Email and I went to my email account. When I click on the edit link, it says Invalid Form URL and underneath it, it says This form is not available for this domain. Is there something I did wrong or does the link not work unless it's an actual form that's been submitted??

  • Profile Image
    Mike_T
    Answered on April 30, 2012 at 07:48 PM

    Your Edit link is correct, but you will need to adjust it a bit in order to solve the "domain" problem.

    Please replace the www.jotform.com with www.jotform.us in your Edit Link:

    old link

    http://www.jotform.com/form.php?formID=21187898973171&sid={id}&mode=edit

    new link

    http://www.jotform.us/form.php?formID=21187898973171&sid={id}&mode=edit

    Please feel free to contact us if you need any further assistance.

  • Profile Image
    MedfordPhotography
    Answered on April 30, 2012 at 08:04 PM

    Thank you!!! That worked! I have a question about it though. Does doing all that (how to make a clickable edit link) enable responders to save what they have completed and continue filling it out at a later date? Like, when they click on the edit link, will what they've already completed be filled in, etc...?

  • Profile Image
    jeanettebmz
    Answered on April 30, 2012 at 08:16 PM

    Yes, you are right and have gotten  the point, the clickable edit link was made for that purpose .

    Let us know if you need further assistance.

    Thank you for choosing Jotform!

    Jeanette

  • Profile Image
    MedfordPhotography
    Answered on April 30, 2012 at 09:26 PM

    When I tried everything out, and I clicked on the edit link from my email, the information I had previously entered in the form was not saved. It was a blank form.

  • Profile Image
    jeanettebmz
    Answered on April 30, 2012 at 11:03 PM

    http://www.jotform.com/form.php?formID=21187898973171&sid={id}&mode=edit

    Make sure you get the Submission Id (sid) placed on the Email template as indicated into the guide

    Make another test and you should get the clickable link with the SID for that particular submission

  • Profile Image
    MedfordPhotography
    Answered on April 30, 2012 at 11:25 PM

    That's the exact link I have in the body of the autoresponder email, but just incase, I copied and pasted the link above in its place. I tested it again and it still didn't save any of the answers I put in.

  • Profile Image
    jeanettebmz
    Answered on May 01, 2012 at 12:32 AM

    Hi, I think the link in your case should be modified, I pasted the wrong one

    http://www.jotform.us/form.php?formID=21187898973171&sid={id}&mode=edit

     

    Let me know if it sorted out the issue.

    Jeanette

  • Profile Image
    MedfordPhotography
    Answered on May 01, 2012 at 12:43 AM

    I replaced the link with the one above and tested it again. Still takes me to a blank form and it didn't save any of my answers. I'm kind of concerned, too, at how many of my monthly submissions that have been used just testing this.

  • Profile Image
    jeanettebmz
    Answered on May 01, 2012 at 12:55 AM

    I can see that , however, let me inform you there is another thread with similar issue, for that reason, the issue has already been escalated to 2nd level

     

    Jeanette

  • Profile Image
    MedfordPhotography
    Answered on May 01, 2012 at 12:58 AM

    So there is no way to fix this, at this time? Meaning, there is no way for my respondants to save their responses and continue filling out their forms at a later time?

  • Profile Image
    liyam
    Answered on May 01, 2012 at 03:32 AM

    I noticed some issues when I received an auto responder.

    In the email, the text for the edit link appears as this:

    http://www.jotform.us/form.php?formID=21187898973171&sid=201666427514752208&mode=edit

    But when I checked where it is pointing, it appears as this:

    http://www.jotform.us/form.php?formID=21187898973171&sid={id}&mode=edit 

    This is why the submitted form is not getting pulled up for editing.  When I checked further why this is happening, I found out that you have the value of { and } URL encoded as %7B and %7D

    Please change these %7B and %7D to { and }

  • Profile Image
    MedfordPhotography
    Answered on May 01, 2012 at 11:21 AM

    I don't understand what you mean by the %7B and %7D? I don't see those anywhere. I did, however, change the link and where it was point to, to http://www.jotform.us/form.php?formID=21187898973171&sid={id}&mode=edit. When I tried it out this time, it took me to a form that had saved answers from when you submitted a test, not my saved answers. Maybe this has to do with the %7B and %7D that I don't see anywhere??

  • Profile Image
    liyam
    Answered on May 01, 2012 at 12:10 PM

    It seems you have changed the link to this: http://www.jotform.us/form.php?formID=21187898973171&sid=201666427514752208&mode=edit so you won't see anymore the link.  But it was located here:

    %7B is the URL encode value of {
    %7D is the URL encode value of }

    I'm not sure how you're able to copy the link with the special characters as URL encoded.  But anyway, I changed the values as how you want it.  You can make tests now and see if it works the way as how you want it.

    Also, can you visit this link if it pre-populates your form with my filled-up submission:  http://www.jotform.us/form.php?formID=21187898973171&sid=201666427514752208&mode=edit

    Thanks.

  • Profile Image
    MedfordPhotography
    Answered on May 01, 2012 at 12:35 PM

    So far, so good. Looks like that worked! Hopefully I won't have any more issues with it. Thank you so much for your time though, and thank you for figuring this out for me! I truly appreciate it!!

  • Profile Image
    jeanettebmz
    Answered on May 01, 2012 at 12:45 PM

    It is good to know the issue was resolved by Lyam

    Hope everything works good now on.

    Feel free to look for future help if you need it.

    We are always glad to assist.

    Jeanette