Not able to submit embedded form with please wait only message

  • Profile Image
    Asked on October 13, 2016 at 04:42 PM


    I found your site on an internet search.  Its seems really cool.  I created a form, have embedded it on my site  and it doesn't seem to work.  I've unpublished for the page for now, to avoid any confusion.

    I have filled in the boxes, hit submit button and it freezes with a Please Wait... message.

    Please let me know if there is a step that I missed, or how to fix this issue.



  • Profile Image
    Answered on October 13, 2016 at 10:12 PM

    I test submitted your form but I could not reproduce the issue at this time. The form submitted just fine.

    Here's the video when I did the test:

    Can you also share to us the URL of your website where you used the form. We can also test it on the website to identify any issue.

    Please let us know if issue remains.




  • Profile Image
    Answered on October 14, 2016 at 10:05 AM


    Ok, Just tried it again, still having the same issue.

  • Profile Image
    Answered on October 14, 2016 at 11:23 AM

    I notice that you are embedding the form using a form embed plugin on your WordPress website. Could you try embedding the form using the default Javascript embed script from the publish wizard?

    Please make sure that you have disabled the form embed plugin to avoid conflicts. Let us know how it goes. 


  • Profile Image
    Answered on October 14, 2016 at 12:36 PM


    That worked.