After integration with Stripe, my Thank you page of JotForm is not coming after person clicks the sign up button

  • Profile Image
    naturestale
    Asked on October 16, 2016 at 08:26 PM

    Initially, the thank you page was coming but on Friday when I activated/integrated it with Stripe, the Thank You page from JotForm is not getting displayed after the customer clicks the final signup button. Please help.

    Thanks

  • Profile Image
    Boris
    Answered on October 17, 2016 at 06:05 AM

    I have cloned your form into my account for testing, and upon making some test submissions, the form correctly presented the Thank You page each time:

    Can you please try submitting your form over its direct link, and see whether the Thank You page is shown correctly:

    https://form.jotformeu.com/form/62417457509360

    If the form works correctly over the direct link, and the issue only manifests when embedding the form into your website, I would recommend embedding the form with our iFrame embed method:

    https://www.jotform.com/help/148-How-to-get-your-Form-s-Iframe-Code

    Please let us know how it goes.

  • Profile Image
    naturestale
    Answered on October 17, 2016 at 11:45 AM

    Thanks for this Boris.

    When you say "embedding the form with our iFrame embed method" do you mean embed it in Wordpress or Stripe? As we are using Stripe as our payment method.

  • Profile Image
    Charlie
    Answered on October 17, 2016 at 01:08 PM

    You'll need to embed the form on your Wordpress website using the iFrame embed code, if that's where it gets stuck.

    This is your form's direct link: https://form.jotformeu.com/62417457509360, could you please try filling out the form using that link? If it went successfully, then the problem is more related between your Wordpress and your form's embed code.

    To avoid a script conflict between your Wordpress and your form's resources/codes, you can re-embed the form using the iFrame embed code instead. Here's how to get that: https://www.jotform.com/help/148-How-to-get-your-Form-s-Iframe-Code. After that, test your form directly on your website.

    Make sure to remove the old embed code before adding the new one.

    Let us know if that works.

  • Profile Image
    naturestale
    Answered on October 18, 2016 at 07:53 PM

    Thanks a lot! It seems to be working now :)