What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why required fields are not working?

    Asked by mynextpet on October 20, 2016 at 02:28 PM

    Hello,

     

    On our AAL Cat Application Form "Ages of Children in the Home" is a required field but many people are leaving that blank & the system unables them to submit the form.

    Page URL:
    http://mynextpet.com/cat-application

    application form required field hello system
  • Profile Image
    JotForm Support

    Answered by Nik_C on October 20, 2016 at 05:27 PM

    I wasn't sure I understood, do you have a problem that people are able to submit the form even though they didn't fill required fields?

    I checked your form and I was not able to replicate this error:

    Please let us know if the issue persists or if you had something else in mind.

    Thank you!

  • Profile Image

    Answered by mynextpet on October 22, 2016 at 11:44 AM
    The specific fields “Number of People in Household” & “Children in the home? Ages? are being left blank & then people have been able to submit even though we made them required fields.
    Thanks,
    Jill Woodall
    Animal Adoption League
    ...
  • Profile Image
    JotForm Support

    Answered by Nik_C on October 22, 2016 at 03:36 PM

    Thank you for additional information provided. I tested your form, but I wasn't able to replicate this problem.

    I checked your submission and indeed there is 'Number of People in Household' that is empty, even though it is set as required field. But, on the other hand, when I checked your revision history, I see that that field is recently added, that would explain the empty fields in submissions.

    Regarding other two fields, I didn't find submission that has those two fields empty.

    Did you add 'Number of People in Household' just now, as it is in Revision history or you had it before, since, again, I wasn't able to submit your form without filling those fields.

    We'll wait for your response.

    Thank you!

     

  • Profile Image

    Answered by mynextpet on October 23, 2016 at 10:44 AM
    Hi,
    The form is called AAL Cat Application Form.
    The field I added "Number of People in Household" & Children one I just updated description are required.
    Form send to us today but field about children description is different & neither field filled in.
    Is there another form connected to our website?
    ...
  • Profile Image
    JotForm Support

    Answered by Nik_C on October 23, 2016 at 12:07 PM

    I tested your form again but every time I get the error:

    And as it should, I'm not able to submit the form.

    I cleared your form's cache and updated those two fields again so please test and let us know if the issue persists.

    Also, could you please share the URL of website where this form is embedded so we can test that as well?

    We'll wait for your response.

    Thank you!

  • Profile Image

    Answered by mynextpet on October 23, 2016 at 12:44 PM
    URL of AAL Application
    http://mynextpet.com/cat-application
    Jill
    AAL
    ...
  • Profile Image

    Answered by Irshad on October 23, 2016 at 01:31 PM

    The Form URL which is embedded on your webpage is: https://www.jotform.com/31154526307953

    I also checked your web page: http://mynextpet.com/cat-application. And I am able to see all the required field validations are working properly. And I am unable to submit the form, without filling the value in required fields. Please check the screenshot below:

    I would suggest you to clear your Browser's Cache or try to check it in different Browser.

    If you still face issue, or need further assistance, feel free to revert back.

    Thank you!