What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Geocomplete widget: It has stopped working.

    Asked by Johnschweighardt on October 20, 2016 at 08:56 PM

    Nothing is displaying as I enter in the address.  Broke on all my forms.  Created a simple test form and it too is not working.

     

     

    Page URL:
    https://form.jotform.com/62937805466164

    stopped working geocomplete widget geocomplete My Forms test form all and
  • Profile Image
    JotForm Support

    Answered by Helen on October 21, 2016 at 02:48 AM

    Thanks for contacting us.

    I checked your test form and one of your form. They works properly as you can see at the below video. I tested in Safari and Google Chrome.

    Which browser was failed when you tried? Please change your browser or delete your browser caches and try it again. If you would embed the form on your website and form was still failed, share your website direct URL. We can make a further inspection  on it.

    We will waiting your response.

  • Profile Image

    Answered by Johnschweighardt on October 25, 2016 at 09:21 PM

    I am having the same issue again.  I've tried clearing my cache in Chrome and Safari but still having the same issue. Tried it on two Mac's and two iPhones and a windows pc using Edge.

     

    However it does work using aviator browser.

  • Profile Image
    JotForm Support

    Answered by EltonCris on October 26, 2016 at 03:28 AM

    I could not reproduce the problem.

    I've tried different browsers, chrome, firefox, ms edge. They all load the widgets. Are you still having this issue on your side? If yes, can you please check what errors shown in the browser console log? Perhaps there are browser extensions or plugins that block them? Try to reset your browsers, see if this makes a difference.

    We'll await your reply. Thanks!

     

  • Profile Image

    Answered by mousesoftaustralia on October 26, 2016 at 03:51 AM

    This issue might be due to the daily quota being exceeded. It's happening for us too.

     

  • Profile Image
    JotForm Support

    Answered by seth on October 26, 2016 at 07:26 AM

    I am also not able to replicate the issue. Could you please check what @mousesoftaustralia mentioned? Please turn back to us with the result.

    You can check it while using your form in inspection mode. Right click on the form and click inspect, then screen the console:

  • Profile Image
    JotForm Support

    Answered by seth on October 26, 2016 at 07:51 AM

    I talked to our developers and they will look at this issue. The issue is probably a temporary one.

    You will be informed about the issue with this thread. 

    Thank you.

  • Profile Image

    Answered by aghub on November 03, 2016 at 05:16 PM

    Hi any update on this? its getting really frustrating.

  • Profile Image
    JotForm Support

    Answered by BJoanna on November 03, 2016 at 06:41 PM

    Unfortunately this issue is still not resolved. One of our developers is assigned to this ticket and priority of this ticket is set to very important. Once this issue is resolved we will inform you via this thread. 

    Thank you for your patience. 

  • Profile Image

    Answered by aghub on November 10, 2016 at 07:38 PM

    any update on this??? it has been nuisance for quite a while now and we are no where close to a resolution or an update?

    The address lookup still does not work....

    When looking at this in developer mode, The warning is now showing as 

    util.js:210Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

     

    Can we get some urgent action on this??? we were on the path to buying a subscription but this issue is preventing us from thinking about that...

  • Profile Image
    JotForm Support

    Answered by Jim_R on November 10, 2016 at 09:12 PM

    @aghub, I'm seeing that this thread is still open and is currently assigned to one of our developers, just like how my previous colleague explained it on an earlier post.

    As promised, we'll keep you apprised on this thread if/when there's an update. For now, we can only request for your patience and cooperation while this is being looked at.

  • Profile Image

    Answered by MaidTeamSix on November 17, 2016 at 05:42 PM

    I'm also having this issue on all my forms as well. Looking forward to an update soon!

  • Profile Image
    JotForm Support

    Answered by Jim_R on November 17, 2016 at 06:59 PM

    @MaidTeamSix - Since you replied here, you will also be informed via email for each and every update on this thread.

    In case you prefer to be updated on your own thread, we would request you to open one by going to this page.

  • Profile Image

    Answered by aghub on November 22, 2016 at 07:40 PM

    Hi any ETA of when this will be resolved?? we haven't been able to send the form out for testing because of this issue.

  • Profile Image
    JotForm Support

    Answered by Jim_R on November 22, 2016 at 08:53 PM

    Sorry but we can't give you a timeframe on when this will be resolved so what I'd do is followup with the concerned team. Thanks for your patience and cooperation.

  • Profile Image

    Answered by mousesoftaustralia on November 23, 2016 at 11:14 PM

    Hey Jotform,

    This is a major issue for us, we have forms that are provided to clients and we can stand to lose them if this is not rectified. It seems so intermittent but has been plagued with problems for about 3-4 months now.

    If paying more is what's required we can do that but until this widget is stable it has hard to switch a tier.

  • Profile Image
    JotForm Support

    Answered by BJoanna on November 23, 2016 at 11:41 PM

    @mousesoftaustralia 

    Unfortunately this issue is still not resolved. Paying more is not required. I will check with our developer to see if there is any update. If there is we will update you via this thread. 

    Thank you for your patience.

  • Profile Image
    JotForm Support

    Answered by TitusNdoka on November 25, 2016 at 09:00 AM

    Thank you for your patience. 

    Google have updated the terms of use for their Google Maps Service, requiring all integrations to use an API Key. 

    Please do the following:

    1. Open your Geocomplete widget settings and click on "update"

    2. Reopen the widget's settings again, then go to the very last setting - follow the instructions there to add an API Key via your Google Account. 

    This will prevent any service interruptions. 

    Let us know if you need help with this. 

     

  • Profile Image

    Answered by mousesoftaustralia on November 28, 2016 at 10:05 PM

    So I tried it on the Address Wiget and also on the Geocomplete, but neither of them work. Tried two different API keys too that we have. This API works for another app we use it for so it's definitely working.

  • Profile Image
    JotForm Support

    Answered by TitusNdoka on November 28, 2016 at 10:38 PM

    Sometimes its a matter of browser cache, so testing on a different browser might show positive results - but in any case, please share the form URL(s) and we'll gladly take a look.   

     

  • Profile Image

    Answered by mousesoftaustralia on November 28, 2016 at 11:45 PM

    Hey Titus,

    Here's the link:

    https://form.jotform.co/60408357922861

    I did try and open it up in Firefox but it's the same result. Is there something I may need to do on the Google Account itself?

  • Profile Image
    JotForm Support

    Answered by seth on November 29, 2016 at 12:26 AM

    Hello,

    We have cleared your form cache. Could you please try again and turn back to us with the results? If you are still having troubles, please send us screenshots of the issue as well as console outputs.

    Thank you.

  • Profile Image

    Answered by mousesoftaustralia on November 29, 2016 at 01:39 AM

    Hey Seth,

    So it looks like it's working on Chrome now, but I tried it on Firefox and Edge, but neither of them work.

    I get this error on my Firefox console, not sure if it means anything or not

    .

     

  • Profile Image

    Answered by mousesoftaustralia on November 29, 2016 at 01:41 AM

    Actually scratch that, it's fixed itself now. I will let you know if it runs into trouble as I need to check with the client now. Much thanks.

  • Profile Image
    JotForm Support

    Answered by seth on November 29, 2016 at 01:50 AM

    Hello @mouseofaustralia,

    I replicated the issue on my side using FireFox browser.

    I created a new thread about this. Please follow up there:

    https://www.jotform.com/answers/999544

    Thank you very much.