Submit button is not working on form

  • Profile Image
    TampaSportsAuthority
    Asked on October 25, 2016 at 03:46 PM

    The submit button is not working on a form on our website: http://www.tampasportsauthority.com/procurement-services  then you go to "submit vendor registration form" please someone let me know what the best thing to do to correct this problem asap. Thank you!

  • Profile Image
    david
    Answered on October 25, 2016 at 04:17 PM

    I addressed your request in your other thread here:

    https://www.jotform.com/answers/970760

    Your form does look to be working at this time.  If it will still not allow for submission on your end, let us know and we will be happy to have another look.

  • Profile Image
    TampaSportsAuthority
    Answered on October 25, 2016 at 04:25 PM

    I am still having the same issue.. it just says "please wait" after I submit and its been 8 minutes of it just saying that.. what should I do

  • Profile Image
    david
    Answered on October 25, 2016 at 06:24 PM

    I tested your form once again from the link in your page and the submission went through without delay.  I tested my clone of your form several times as well, it also was allowing for submissions without delay.

    Try filling out the form using either Google Chrome or FireFox if your are not already.  If both of those produce the same issue, let us know and we will be happy to investigate further.

  • Profile Image
    TampaSportsAuthority
    Answered on October 26, 2016 at 08:53 AM

    We just tested it and it seems to be working just fine now.  Thank you so much for your help and assistance with everything!! Have a great day!

  • Profile Image
    Jan
    Answered on October 26, 2016 at 10:54 AM

    Glad to hear that it is already fixed. If you have any issues, please let us know. Thank you.

  • Profile Image
    TampaSportsAuthority
    Answered on October 31, 2016 at 08:47 AM

    Good Morning

    The form is doing it again, it just keeps saying please wait and never submits... we got into work this morning with 6 emails from vendors saying it.  Please advise...  I haven't seen a submission come through since the "test" one... so not sure that it has been properly working since... Thank you

  • Profile Image
    Jan
    Answered on October 31, 2016 at 10:36 AM

    @TampaSportsAuthority

    This is a duplicate thread. We'll attend to your issue on this thread: https://www.jotform.com/answers/970760.

    Thank you.