The "New Substring" widget will not allow for opening the form in the Advanced Designer

  • Profile Image
    oztechs
    Asked on October 26, 2016 at 03:09 AM
    I can't access the advance designer not the Theme designer, when clicking on any of those advance controls all I get is a white blank webpage.
  • Profile Image
    EltonCris
    Answered on October 26, 2016 at 03:12 AM

    I checked this on different browsers but I could not reproduce the problem. Can you please try to relogin from your account and check it again? Have you tried checking it on different browsers for testing purposes?

    If that doesn't help, try to append this parameter #design in the form builder URL.

    Example: https://www.jotform.com//?formID=62985301351959#design

    Let us know if you are still not able to load the form designer after this.

    Thanks!

  • Profile Image
    oztechs
    Answered on October 26, 2016 at 10:44 PM
    I did confirm that I am able to open the advance designer from a different form that does not have as many fields or special gadgets however this form is not allowing me to open the advance designer: https://www.jotform.com/?formID=61252684803153
    Ofer S. Zur | OZtechs
    Experience the Magic of Technology
    Main: (925) 280-7400,ext 6101 Fax: (925) 271-4606
    "Things turn out best for the people who make the best of the way things turn out"
    John Wooden
    ...
  • Profile Image
    Irshad
    Answered on October 27, 2016 at 03:09 AM

    I have checked your form: http://jotform.com/61252684803153. But I am not able to see any issue, in your Form. I also tried to open Advance Designer for your form, and I am able to open it without issue.

    Please note, first you need to create the "Design" icon in Form builder, and then need to click on the "Advanced Designer" button at the bottom side of new popup, according to the below screenshot:

     

    I would suggest you to clear Browser's Cache, or try to check it in different Browser.

    If you have any query, or need further assistance, feel free to revert back.

    Thank you.

     

  • Profile Image
    oztechs
    Answered on October 27, 2016 at 12:44 PM
    I have attempted to use the feature from 4 different browsers and two different computers and I get the same results each time.
    Get Outlook for iOS
    ...
  • Profile Image
    david
    Answered on October 27, 2016 at 02:35 PM

    I tried opening your form in the advanced designer and was unable to do so.  This is what was shown when trying to open it:

    I am able to reproduce the issue even when cloning the form to my own account.  There is an error in the console:

    It looks like "New Substring" widget is the cause:

    Removing that widget allows for the form to be opened in the form designer once again.

    I will forward this to our developers to have a look.  In the mean time, removeing that widget from your form will allow for opening the form in the advanced designer.

  • Profile Image
    TitusNdoka
    Answered on November 02, 2016 at 09:52 AM

    Please use the Substring widget which has the latest updates:

    http://widgets.jotform.com/widget/substring - it should work with the advanced designer. 

    I'm afraid the "New Substring" widget you have is not currently supported. 

    We apologize for that confusion as you might have found the widget in our Widget gallery (which was not our intent). 

    If you have further difficulty, please let us know.