Allow Multiple function problem - only one file is attached to the submission

  • Profile Image
    quore
    Asked on May 07, 2012 at 11:55 AM

    Hi

     

    i'm having a problem on a form i just created with the Allow Multiple function on file upload tool.

    it seems that only one file (the last uploaded) is attached to the form.

    Plz can you check this?

     

    Thank you!

  • Profile Image
    pinoytech
    Answered on May 07, 2012 at 12:14 PM

    Hi,

    Upon checking this form: http://www.jotformpro.com/form/21274010003936 I don't find any problem on this. Upload button is working properly. Please take a look here.

    Have you tried already deleting your website browsing cache and cookies? If not, please give a try.

    Thank you!

  • Profile Image
    quore
    Answered on May 08, 2012 at 03:33 AM

    Hi

    yes the upload is working fine but when you submit the form only the last file is attached and not all uploaded files.

     

    thank you

  • Profile Image
    idarktech
    Answered on May 08, 2012 at 05:33 AM

    Hi,

    I just send a sample submissions with your form with 3 files attached namely:

    jottformtest1.txt

    jottformtest2.txt

    jottformtest1.txt

    Can you please check if you were able to received this 3 files? If not, kindly update us here so we can help you further with this.

    Thanks!

  • Profile Image
    quore
    Answered on May 08, 2012 at 05:52 AM

    hi

    your submission is correct! i can see 3 attachments, but when i try to send multiple files it's not working. 

    Am i doing something wrong?

     

    Thank you

  • Profile Image
    idarktech
    Answered on May 08, 2012 at 06:03 AM

    Hi,

    Thanks for your fast reply, appreciate it.

    Can you please clarify us on what you mean with "send multiple files"? I was actually sending multiple files with your form, kindly correct me if this is not what you mean here.

    Also, can you please recheck it yourself if everything is working fine now?

    Thanks!

  • Profile Image
    quore
    Answered on May 08, 2012 at 07:22 AM

    Hi

    I'm testing the form these days 

    and so far only in the submission you made with the 3 txt files everything worked fine.

    When I make a test submission with 3 docs for example - only one doc stays when i hit the submit button. 

     

    Check this image

    All these test submissions have 2 or more files attached via the Allow Multiple function but only your submission displays correctly all the files. All the other submissions i made have one or none file attached.

    http://www.hypersys.gr/images/stories/allow_multiple.jpg

    thank you

  • Profile Image
    idarktech
    Answered on May 08, 2012 at 07:59 AM

    Hi Quore,

    I just edited your file upload max file size limit. Can you please recheck again this time? I doudbt this is due to the upload size limit.

    Also, since you're still in testing phase :) I have then reseted your submissions counter. Thanks!

  • Profile Image
    quore
    Answered on May 08, 2012 at 08:54 AM

    Thank you for the reset! :)

    I think the problem is still there but I am sure that it is related with file types.

    I am changing  extensions and testing with various file types to locate the problem.

     

  • Profile Image
    idarktech
    Answered on May 08, 2012 at 08:57 AM

    Hi,

    Yes, please let us know what your results are.

    Thank you so much for your cooperation. I appreciate it much! :)

  • Profile Image
    quore
    Answered on May 08, 2012 at 11:23 AM

    ok here are the results

    Extensions accepted: pdf, doc, docx, odt.

     

    1 .doc uploaded -> no file attached to the submission

    2 .doc files uploaded -> 1 doc attached to the submission

    1 .doc & 1 .docx uploaded -> only the docx attached to the submission

    2 or more .docx uploaded ->  works fine!

    1 or more .pdf uploaded -> no file attached to the submission

    1 .doc & 1 .docx & 1 .pdf uploaded -> worked fine the first time with all the files attached but when I changed the file order the doc file was lost.

     

    so i started to change the file type order so:

    first file .doc & second file .pdf  --> no file atached to the submission

    first file .pdf  7 second file .doc --> works fine!

    really weird...

     

    what do you think is happening? I really can't understand the problem

     


    Thank you!


  • Profile Image
    liyam
    Answered on May 08, 2012 at 03:33 PM

    Hello, can you please share with us the URL of the form in issue?

    Thanks.

  • Profile Image
    idarktech
    Answered on May 08, 2012 at 07:31 PM

    @quore,

    I tried replicating this issue again but failed to do so. I was able to received the .doc files completely, no missing files. Check this screen: 

    https://cms.jotform.com/uploads/image_upload/image_upload/global/6394_submissions_attached.png

    As part of this investigation, I would suggest you to delete your file upload field and then create a new one.  Set again its settings and then recheck.

    You can also test my form here. Try to upload your fields here and I'll give you the submissions result.

    Looking forward to your response. Thank you so much for your patience!

  • Profile Image
    quore
    Answered on May 09, 2012 at 05:58 AM

    Thank you very much

    I just used your form. I attached 2 docs, 1 pdf and 1 docx.

    I will try to create a new upload field and also check again.

  • Profile Image
    quore
    Answered on May 09, 2012 at 05:17 PM

    Can you tell me if the 4 files i attached to the form were uploaded to the submission correctly?

    Many thanks!

  • Profile Image
    Mike_T
    Answered on May 09, 2012 at 06:05 PM

    As far as I can see, they were successfully uploaded:

    If your main issue still persists, please let us know.

  • Profile Image
    quore
    Answered on May 10, 2012 at 02:12 AM

    thank you very much!

    can I use the form you created?

  • Profile Image
    jonathan
    Answered on May 10, 2012 at 05:01 AM

    @quore,

    Hi, by all means. Yes you can.
    Please clone idarktech's form.
    Just in case -- here is the guide -How-to-clone-an-existing-form-from-a-URL .

    Just inform us if you still have other concerns on JotForm. Thanks.

  • Profile Image
    quore
    Answered on May 10, 2012 at 01:13 PM

    Hi again

    I still have the same problem. I don't know what is causing the problem but the upload function is totally unstable. Sometimes the files come with the submission and sometimes not. I cant use this function right now and push it to a lie site because I'm not sure that is working.

    I could use the single file upload button but I cant translate the button text.

    Is there a way to change the single upload button text? ("Choose file" & " No file chosen" )

     

    Thank you

  • Profile Image
    jeanettebmz
    Answered on May 10, 2012 at 03:21 PM

    I made a test , using my own form, and I can see the submission with the attachment file into my submissions inbox (in the form builder) ,but the  attachement doesnt' come up with the submission into my email inbox

    As far as I know that is normal. However, my colleagues might come with a better explanation

    Regarding to the single upload button, yes, you can customize the label, but I don't know if you refer to the "browse" button, in that case, it will show up the language of your current OS

    You might also want to translate the warning message, in case your form contains a required upload field, here it is how

    Cheers!

    Jeanette