What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why widgets on my form are not being included in the email auto-responder?

    Asked by kmatsune on October 31, 2016 at 07:33 PM

    Hello,

     

    I created a survey and at the end, there is a Configurable List where I need people to input product information. I want them to get a confirmation email with all the information they submitted on my form, including the information from the configurable list. However, the answers from the configurable list do not show up in the person's confirmation email.

     

    I tried with my own email and it worked fine - I got the response email and the confirmation email both with the configurable list answers. However, when I sent it to another person, their email confirmation did not have the answers they put in the configurable list. I put it in the email I created "Autoresponder 1" and it still doesn't show.

     

    How can I change this?

     

    Thank you,

    Kara

    section email survey product hello all
  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 01, 2016 at 01:11 AM

    I have cloned and tested your form, I was able to replicate the issue, seems like both widgets are not being included, I have checked the names of the widgets and they seem correct.

    However, I have deleted the current email auto-responder and added a new one, this way I removed any change made to the email template. 

    If possible, I would suggest you to do the same on your end, this way you will also get the email with the updated info from your form, here is also a screenshot about my last test, when I already removed and added the email: 

    This guide will help you to delete the email auto-responder from your form: How-to-Delete-Notifications-Autoresponder

    And this one will help to add the email auto-responder again: Creating-a-Form-Autoresponder

    With the email notifications this does not seem to be a problem since on my tests I can see the info is being properly included in the email. 

    Please if the issue still persists, let us know. 

  • Profile Image

    Answered by Kara  on November 01, 2016 at 11:44 AM

    Hello,

     

    The problem is still persisting. The two bottom widgets don't show up in the autoresponder email at all. I completely deleted it and re-added and it still does not work.

     

    Also, on the notification 1 email, it stops showing the chart when I try to put in words on the left column (product requested and I understand). Before I put words in those two boxes, the chart and the other widget showed up.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 01, 2016 at 01:19 PM
    Apologies for the inconveniences. 
    I have just checked your form and I can see you've changed the Configurable List widget that you were using to another one, please do note that on this new widget you will need to click on the "Add Row" button, otherwise the data entered in the widget will not be recorded:
    I have also submitted a test and I can see the info is being included properly in the email notification, here is a screenshot of it: 
    I can also see you've currently removed the email auto-responder from your form: 
    Could you please add it once again so we can test with the new widget you're using in your form? 
    We'll wait for your response. 
  • Profile Image

    Answered by kmatsune on November 01, 2016 at 01:24 PM

    Hello,

     

    I have readded the email.

     

  • Profile Image

    Answered by kmatsune on November 01, 2016 at 01:40 PM

    I would prefer to use the widget I used prior to this one, but I changed it hoping it would show up in the confirmation emails but it didnt.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 01, 2016 at 03:15 PM

    I have now checked your form and I found you have added a label text to the Matrix Dynamic widget so it shows in the emails, here is a screenshot about what I could get when submitted your form: 

    However, you could see that the last widget, Terms & Conditions, does not appear there, when I added a label to your form then the widget started to appear, here is a screenshot of my last test where you could see both widgets included, and both with labels on it: 

    I have tested this and I cannot replicate the issue on my end, the widgets are being included even if they do not have label texts on them: 

    I'm using on my cloned version the Configurable List widget you were using before, so I would suggest you to test this on your end and see the result, please add a label text to your widgets and submit it, both should be included, if you want you could also restore the previous widget you were using. 

    If this is the case and the fields with labels are included then we could apply a workaround to hide labels from the form so they only appear in the email notification. 

    Looking forward to your response. 

  • Profile Image

    Answered by kmatsune on November 01, 2016 at 03:29 PM

    The terms and conditions row still doesn't show up on the emails from the autoresponder - even if I label it. However, it does show up on the notification one.