What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Experiencing a Dropbox Integration bug

    Asked by nfusso on November 01, 2016 at 03:19 PM

    Hello Jotform community,

    I am experiencing a Dropbox integration bug, and hoping someone can help.

    I recently setup a form, linked below. I was able to successfully authenticate my Dropbox account, could designate the proper Dropbox folder to receive uploads, and received an "integration success" message. However, upon testing my Dropbox folder never receives uploaded data.

    https://www.jotform.com//?formID=42508024102944

    A few items I already tested:
    1) The form properly works. I can view the uploaded data on Jotform, and also see it in a Google Sheet integration
    2) The test data works to, for the reasons shared above
    3) This process has worked before. I've set up 50+ other forms using this same method, and dropping data into the same dropbox folder

    Any ideas on how to resolve this issue?

    Nicholas

    Page URL:
    https://www.jotform.com//?formID=42508024102944

    dropbox
  • Profile Image
    JotForm Support

    Answered by Mike on November 01, 2016 at 09:32 PM

    Thank you for contacting us.

    The Dropbox integration seems to be fine on my end, and also we are not getting similar reports from other users. Could you please redo the Dropbox integration to see if that makes any difference?

    If this does not help, please let us know.

  • Profile Image

    Answered by nfusso on November 02, 2016 at 03:28 PM

    Thanks for the quick response Mike! I'm still experiencing the problem, but think I have honed in on the issue area.

    Here's what I did:


    -- I redid the Dropbox integration. In the "Creating your Dropbox Folder" options, I set the folder path to be: My Dropbox\Project\{submissionID}. This worked!


    -- I then set the folder path to include a sub-folder. The new path is: My Dropbox\Company\Project\{submissionID}. This failed.

    In this case, including the Company>Project path broke the integration. My thinking is that including a sub-folder in the folder path is causing the problem. This is unusual, because I have other forms that successfully download form data into sub folders. 

    Any thoughts on what might be happening here?

  • Profile Image
    JotForm Support

    Answered by Mike on November 02, 2016 at 05:14 PM

    Please try replacing the backslash with the common slash.

    Company/Project

    It worked on my side with that setup.

    Thank you.

  • Profile Image

    Answered by nfusso on November 02, 2016 at 05:19 PM

    That worked. Thanks for the easy fix!