Form Won't Update

  • Profile Image
    mbyars
    Asked on May 09, 2012 at 08:39 AM

    Hi There:

    I recently (last week) updated one of my forms then saved it, but when I click on the link to it on my site, it's still missing the update.  

    Here's the link to the form: http://form.jotform.com/form/10992634354

    In the top drop-down and at the bottom, it's supposed to have a "Create Your Own Radio Show" choice, but it's not appearing in the form even though I've updated and saved it on the form itself.  Again, it's been over a week since I first updated it, and I've also done multiple hard refreshes in my browser, to no avail.

    Help!

    Thanks,

    Matt Byars

  • Profile Image
    markashton
    Answered on May 09, 2012 at 08:46 AM

    I too have this problem. I am updating in  real-time and when I try in all browsers the form is not updating.

    http://form.jotformpro.com/form/21143609596962

    I have changed the forms title to Patient Satisfaction Questionnaires .... with an 's' on the end to demonstrate this

    Here's the thing .... DO NOT ASK ME TO CHANGE THE URL OR CLONE THE FORM

    Respectfully, I cannot do this. This would mean hours of work

    Why does this phenomenon consistently happen?

    Regards Mark

  • Profile Image
    liyam
    Answered on May 09, 2012 at 11:54 AM

    Hello Matt.  I tried modifying your form and I was able to do it.  Can you try editing your form again?  I also suggest for you to try clearing your browser's cache first before doing so.  In addition, please make sure that you do not have the same form open in another tab while in the form editor/builder.  Otherwise, it will just overwrite each other which will cause for your form not to save properly.

    Hello Mark,  can you also do the same (clearing your browser's cache before editing again)?  I tried modifying your form's title to Patient Satisfaction Questionnaires (adding an s) and I was able to update it (although it was a bit slow. Probably due to the length of your form)

  • Profile Image
    markashton
    Answered on May 09, 2012 at 11:58 AM

    liyam,

    I had to change address in the end. I know all that cache thing ... tried that ... and 4 different browsers. This is a consistent problem that needs addressing ... updating regularly stops happening ... and its not a cache issue. One only has to do a search on "Form update" to see that there is a problem with loads of users.

    Instead of doing loads of rollouts of integration look at the consistent complaints that come across from users and iron them out first

    Regards Mark

  • Profile Image
    mbyars
    Answered on May 09, 2012 at 12:45 PM
    Hi Liyam:
    Working now--thanks.
    Best,
    Matt
  • Profile Image
    pinoytech
    Answered on May 09, 2012 at 12:56 PM

    In behalf of my colleague Liyam, you're welcome. Let us know if you need further assistance.

    Thank you!