The form is not saving on my form builder

  • Profile Image
    SchoonerSail
    Asked on November 05, 2016 at 07:31 PM

    Exactly the same for me - just lost a couple of hours work.

    Seems this is a common problem.

    Best to regularly check revisions are happening.

  • Profile Image
    John_Benson
    Answered on November 06, 2016 at 06:07 AM

    Sorry for the inconvenience.

    We need to investigate this further and check if someone else is having the same issue about the Save button. In the meantime, try clicking the Preview Button. The form will auto-save whenever you Preview the form.

    Feel free to contact us again, if you need further help. Thank you.

  • Profile Image
    SchoonerSail
    Answered on November 06, 2016 at 06:11 AM

    Hi

    Thanks for the quick response.

    It is not such a big problem now I know it might happen. I just keep an eye to see that the form is saving correctly.

    All in all so far I am very impressed with the form building and all the options. 

     

  • Profile Image
    Kiran
    Answered on November 06, 2016 at 12:38 PM

    Thank you for your feedback. I have checked the form builder and see that the form is saving correctly at the moment. If you experience the issue again, please make sure that you are logged in to your JotForm account by using a different tab on the same browser. 

    You may also try using a different browser. It is recommended to use Google Chrome or Mozilla Firefox to use with JotForm. 

    Please get back to us if the issue still persists. We will be happy to look into the issue further.

    Thanks!