What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    File Upload: Submit button is not changed to 'Please wait...' in Safari

    Asked by peterpwa on November 14, 2016 at 07:54 AM

    File upload field: Works for me but nobody else

    I pointed this out on an old thread and you didn't reply.

    Ok the file upload form is not working to anyone else. When I try it, it works.

    Customers are now sending me files by email saying they cant use the upload or they are using my old upload form.

    Can you please find out what is wrong? Even my regular customers are using my old uploader.

    www.pwauk.com/upload.htm

    Please what can I do?

    safari upload form
  • Profile Image
    JotForm Support

    Answered by owen on November 14, 2016 at 08:11 AM

    Hi Peter,

    I have cloned your form and ran a test submission on it. Everything seems to be working as expected. I managed to upload my files without an issue. 

    I have also run a test submission on your actual form. Since it is embedded on a website, I wanted to see if the field would act differently. Still, I managed to submit the form successfully. 

    If you could ask your users to provide you a screenshot of the error they are getting it would be a huge step forward for us to find out what the issue is. On my end, I am not able to reproduce the issue despite the fact that I have run many different tests. 

    It would be also good to know if this issue occurs when a certain type of file is tried to be uploaded. 

    We will be waiting for further details. Thank you for contacting us. 

  • Profile Image

    Answered by peterpwa on November 14, 2016 at 09:48 AM

    Ok thank you for testing. My friend had no problem either.

    I have just a call from a school trying to upload and they are using Safari. presumably that is a mac, they say it just hangs, they select the file and submit and it says uploading and then just hangs at this point then it timeout.

    He thinks it maybe something on the new version of safari? I don't know if a new version has been releases as I don't use safari. He retried on Chrome and it worked.

  • Profile Image

    Answered by peterpwa on November 15, 2016 at 04:38 PM

    Virtually all my customers have said they can not use the upload. Have you done any upgrades in the last few weeks which is causing this problem?

    I just tried it on an ipad using safari and it does not work. when you press the upload button nothing happens and there is an error at the bottom of the page saying there is an error on the page. please fix error befor proceeding or something like that. It works for me when I test it on windows10 using Edge and firefox although one of my customers uses firefox and he couldn't use it either.

    I have redone a new upload using the v4 and 2 new email responders. It all works for me but not on the ipad. If my customers cannot use it I will have to revert back to my old upload page and have all the old problems back.

  • Profile Image
    JotForm Support

    Answered by BDAVID on November 15, 2016 at 05:49 PM

    Could you share a file they had to send you via email, so we can download it, and try uploading it through your form again ? Also, please make sure the file type they are trying to upload is actually allowed in your form:

  • Profile Image

    Answered by peter on November 15, 2016 at 06:02 PM

    Tthe files are Pdf's and jpg files. I can upload the same files to myself and it does seem to work fine when i try it. I'm wondering if it;s a cookie thing.

    Just had another customer say he couldnt upload it.

    Hi Peter,
     
    I tired on Safari first, then Opera and then Chrome and all three just froze on the upload process as well as the alternative upload page you offer.
    Hope that helps.
     
    Engin

    On 15 November 2016 at 15:57, <peter@pwauk.com> wrote:
    Hi Engin, thank you for your order.
    Can i ask what the problem was trying to upload the file? which browser and did it give any error messages?
    I’m trying to find out why as you’re not the first person having problems uploading.
     
    Any info you can give me would help.
     
    Best regards
    Peter
     
    Have you tried my uploader using Safari?
    This is really worrying as this form has been working well till now.
     
  • Profile Image

    Answered by peterpwa on November 15, 2016 at 06:13 PM

    I uploaded his file named shirt A2 posters.Pdf to myself and it worked. you will find that pdf in my submissions. nothing wrong with the file and pdf is listed in what is allowed.

  • Profile Image
    JotForm Support

    Answered by Mike on November 15, 2016 at 09:04 PM

    I was able to reproduce the issue where the Submit button text is not being changed to 'Please wait...' upon the button click using Sarafi on Mac. However, the upload process itself is not affected, once the file is completely upload, the submission is recorded just fine. I have sent a ticket to our developer regarding this upload issue in Safari.

    Are you still getting any reports about failed uploads? When the upload tool is set to accept multiple uploads, it does show the upload progress bar, so that the upload indication should be clear to the end form users.

  • Profile Image

    Answered by peterpwa on November 16, 2016 at 05:42 AM

    I do not get any reports on failed uploads nor is there any files been uploaded. I'm guessing that when they click the button and nothing happens, they give up, specially if it's a large file they probably just give up and try my old one. The reason I am using your forms is because my old  upload would not work with Safari or Chrome. again, it worked in the background but customers thought it did not work.

    The problem I had on ipad using safari was nothing happened when i pressed the upload files button,  I could not even browse for a file. I'm guessing this is what's happening with my customers. One customer tested it while on the phone to me and he could see the progress of the upload but it just hung/stopped, then timed out. He went to chrome and said it appeared to work but I never got his upload so I assumed he did not press submit.

  • Profile Image
    JotForm Support

    Answered by amy on November 16, 2016 at 06:49 AM

    Hello again,

    Our developers are working on this issue. You would be informed as soon as the problem is solved. 

    Thank you for your patience. 

    Regards.