What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Custom date with today+x is not working in form.

    Asked by GOLFTRIPJUNKIE on November 15, 2016 at 08:32 AM

    hi.

    on a majority of my forms, the following has been put into the custom section for arrival date - 'today+7' to show the date in the box. for departure date - 'today+10'. 

    i created a new form, then duplicated that form, and tried to insert both of those into the respective custom areas and the dates that are being spit out are for 2001.

    here is an example of a form that works (titled 'charleston' in my list of forms)

    https://golftripjunkie.com/charleston-quote-form

    here is an example of a form that does not work (titled 'charleston cp' in my list of forms)

    https://golftripjunkie.com/charleston-golf-packages

    with the exception of scotland cp and ireland cp, any form with cp on it in my list of forms i cannot get the custom to work.

    how do i fix this?

    thanks.

    Screenshot
    problem My Forms new form does not work section
  • Profile Image
    JotForm Support

    Answered by ashwin_d on November 15, 2016 at 09:15 AM

    Hello GOLFTRIPJUNKIE,

    I did check your form "charleston cp" and found that you have not set the default date in your date field. I went ahead and set the custom date for arrival (today+7) and departure (today+10) fields and it seems to work as expected. Please check the screenshot below:

     

    Now your embedded form also seems to display the dates correctly. Please check the screenshot below:

     

    I would suggest you to please test your form again and get back to us if the issue persists.

    Thank you!