GeoComplete Widget: Not showing autocomplete options

  • Profile Image
    MaidTeamSix
    Asked on November 17, 2016 at 05:33 PM

    Hello,

     

    The GeoComplete widget is not showing any autocomplete options, and generally isn't working well. 

    Any ways to fix this? It is on all my 'New Client' forms.

     

    Thanks,

    Casey

  • Profile Image
    Mike
    Answered on November 17, 2016 at 09:22 PM

    The GeoComplete widget is based on Google Map APIs, and it seems that Google is limiting requests to their resources.

    I have submitted a ticket to our developers to see if we can implement a solution to this. There is no ETA, but we will let you know if we have any updates.

  • Profile Image
    TitusNdoka
    Answered on November 25, 2016 at 09:06 AM

    Hello,

    Google now requires all integrations with Google Maps to use an API Key. 

    Please go to your widget settings and

    1. Click on "update" to get the latest version of the widget

    2. Add your Google maps API key on the last setting on the widget - you can create one with your Google account if you need one

    Please let us know if you need help with this. 

  • Profile Image
    MaidTeamSix
    Answered on November 28, 2016 at 02:24 PM

    I got my Google Maps API Key from the link provided. After updating the widget with it the widget still does not show autocomplete options.

    Is there another step involved that I am missing?

     

     

  • Profile Image
    Mike
    Answered on November 28, 2016 at 03:05 PM

    Could you please try to update widget's Google Maps API Key field once again? The key was probably not saved on your GeoComplete widget field.

  • Profile Image
    MaidTeamSix
    Answered on November 28, 2016 at 03:11 PM

    I have updated it and it is showing for me, but the form is still not showing autocomplete options.

    This is the form name: New Client (updated 9/30/16) (NYC)

     

    Thanks,

    Casey

  • Profile Image
    Kiran
    Answered on November 28, 2016 at 05:03 PM

    I have checked your JotForm and see that the autocomplete is working properly on the widget. 

    Could you try checking on a different browser and see if it that works? You may also try opening the form in a private/incognito window. Let us know if you need any further assistance. We will be happy to assist.