Conditions: conditions stopped working and conditional logic manu not even opening.

  • Profile Image
    pacollins
    Asked on November 22, 2016 at 02:08 PM

    I have a form that suddenly stopped working. 

     

    Conditions stopped in some cases. I can't even open the conditional logic menu. When you click FAIL on the bottom right, this should open up different fields and it's not. 

     

    Please help me get this resolved quickly!

    203-546-6229 if speaking through this is the best option.  

  • Profile Image
    pacollins
    Answered on November 22, 2016 at 03:30 PM

    I've been tracing back my steps and the only thing that I've done differently today then any of time that this form has been in operation. 

    Today I clicked on EDIT FORM and it brought me to the version 4 screen of my form. The form was made in version 3. I clicked on EARLIER VERSION and everything seemed to go back to normal. 

    A short time afterward is when I started to have the issues I'm still experiencing. 

     

     

  • Profile Image
    BDAVID
    Answered on November 22, 2016 at 05:46 PM

    Your form seems to be working fine now. Let us know if you need more help.

  • Profile Image
    pacollins
    Answered on November 22, 2016 at 06:03 PM

    Not at all on my end. It's still doing the same thing. 

    When I click the fail button, a number of hidden fields should become visible and that isn't happening. 

     

     

  • Profile Image
    BDAVID
    Answered on November 22, 2016 at 07:24 PM

    You are right, I cloned your form, and I could not even open the conditions panel:

    I have forwarded this to our back-end team. You will be updated via this thread when this gets fixed.

  • Profile Image
    pacollins
    Answered on November 22, 2016 at 07:26 PM

    Thanks for your help! We just launched this form and this wasn't at all expected.

    Anything you guys can do to help me get this up and running quick would very much be appreciated!

  • Profile Image
    Chriistian
    Answered on November 23, 2016 at 02:21 AM

    I checked the ticket for this thread and our development team are working on it. We will update you in this thread any updates to the ticket. Sorry for the inconvenience.

    Regards

  • Profile Image
    omur
    Answered on November 24, 2016 at 06:43 AM

    Hello Pacolins,

    We've issued an update to our codebase that should resolve your problem.

    If you're still experiencing problems feel free to write us.

    We're here to help.

     

    Thank you

  • Profile Image
    pacollins
    Answered on November 24, 2016 at 09:18 AM

    Thanks omur! 

    Looks like the conditional logic menu is up and I can fix up the form from there. 

    Out of curiosity, was this something that I did and do I have to worry about this maybe happening again? 

     

     

  • Profile Image
    Chriistian
    Answered on November 24, 2016 at 09:49 AM

    Hi, Glad to hear that the conditions is now up for your form. Regarding on your question, I will have to ask omur (our developer) the details regarding the reason why the issue occurred to your form. We will let you know on this thread.

  • Profile Image
    omur
    Answered on November 24, 2016 at 10:46 AM

    Hello pacollins,

    I'm happy that it did work for you. It was actually related to a technical error caused on our side. Out from millions of forms, it happened about one time and I fixed it quickly.

    My personal guess is that it is very unlikely to reoccur and even if, we're here and ready to help :)

    Thank you very much

     

  • Profile Image
    klevas
    Answered on January 12, 2017 at 02:20 PM

    Dear JotForm support,

    It seems that we started having similar bug with our Conditions logic.

    If I try to amend a condition (edit, not delete), they do not seem to change (remain the same). Condition on field number 84

    But this time it is even more obvious: if I revert back to "working revision" (Jan 5, 3:47pm), and try "delete" any condition, ALL other conditions are getting deleted as well.

    Also, 

    Form ID: https://www.jotform.com//?formID=30363441843955

    Thanks

  • Profile Image
    BDAVID
    Answered on January 12, 2017 at 03:46 PM

    @klevas, your question will be addressed on the following thread: https://www.jotform.com/answers/1033095