What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Going back and forth into Calculation widget breaks it: displayed values are weird

    Asked by Masalamedia on November 23, 2016 at 06:52 PM

    I've been trying to set up a calculation widget but have repeated problems. Yes, I've cleared by browser cache repeatedly.

    If I go in and type commas between values for an average calculation, it doesn't work because the calculation widget sees those commas as text. You have to click twice on commas to turn them into separators. This is not explained anywhere and is confusing.

    Further, if I go back into the calculation a few times, for example to change the # of decimal places to display, eventually the widget breaks and displays the "copyright" © symbol around the calculation and the raw data separated by text commas. I then have to re-do the calculation all over from scratch, which is  big time waster.

    See screen shot https://www.dropbox.com/s/r44incghn6yq0xc/Screenshot%202016-11-23%2015.50.34.png?dl=0

    Page URL:
    https://form.jotform.com/Masalamedia/IwokramaSurvey

    Screenshot
    and displayed values breaks
  • Profile Image

    Answered by Masalamedia on November 23, 2016 at 06:54 PM

    I am continuing to work on this form and cannot have it broken like this. I've cloned the broken version of the form here - please examine.

    https://form.jotform.com/63277614055962

  • Profile Image
    JotForm Support

    Answered by jonathan on November 23, 2016 at 09:39 PM

    I checked it using a cloned version of your form https://www.jotformpro.com/form/22818026430952 and it seems to be working now as it should.

    The calculation formula is good.

    Please let us know if still not resolve.

    Thanks.