No funciona correctamente nuestros formularios

  • Profile Image
    Colegio_Hontanares
    Asked on July 19, 2021 at 10:00 AM

    Buenos días. Hemos centralizado todos nuestros formularios en la plataforma Jotform pero hemos tenido varios inconvenientes con algunos usuarios que nos manifiestan que al estar llenando los formularios, estos se les cae y deben volver a iniciar a llenarlo.

    Podrían por favor validar el posible inconveniente para poder darle tranquilidad a los usuarios de que su formulario sea diligenciado en su totalidad.

    Adjunto los links del formulario:

    https://form.jotform.com/211923771878669

    https://form.jotform.com/203144342729654

    Muchas gracias.

  • Profile Image
    Bojan_J
    Answered on July 19, 2021 at 12:54 PM

    Greetings.

    Can you please let us know do they get any specific error messages? Does this happens with all your forms or only with the ones that you have provided? Do you perhaps know the device and browser your users are using?

    I have tested the cloned version of your form, however, I could not replicate any problems. Would you mind if we make a test submission directly on your form? Also, is your form embedded into your website? If so, please let us know the URL of your page.

    Thank you for your cooperation.

  • Profile Image
    Colegio_Hontanares
    Answered on July 19, 2021 at 04:07 PM

    Hola,

    No hay un mensaje de error, se queda sin mostrar las preguntas y les toca volver a iniciar y normalmente es finalizando el formulario.

    Muchas gracias.

  • Profile Image
    Kevin_G
    Answered on July 20, 2021 at 11:40 AM

    Gracias por los detalles adicionales.

    A pesar que no se muestre ningún error, sería de mucha ayuda obtener una imagen o video de lo que le sucede a los usuarios, de esta manera podríamos identificar que opciones seleccionan los usuarios para que el error se replique. Puedes adjuntar imágenes aquí siguiendo la guía proporcionada por mi colega y si tienes un video puedes subirlo a Dropbox o Google Drive y compartir el enlace acá.

    Ahora, también veo que tus formularios están agregados a páginas web, ¿puedes confirmar si el problema ocurre únicamente con los formularios en las páginas web o si ocurre cuando cargas los formularios usando los enlaces directos?

    También revisé los formularios y veo que hay muchas condiciones con errores, te recomendaría corregirlas o eliminarlas en caso que no sean necesarias, acá te dejo una imagen de estas condiciones:

    1626795575_60f6ee37e2a73_

    Déjanos saber si corrigiendo las condiciones funciona.


  • Profile Image
    Colegio_Hontanares
    Answered on July 23, 2021 at 09:21 AM

    Buen día.

    Voy a continuar el seguimiento con esto que me indicas y reportaré más adelante si persiste el problema.

    Muchas gracias!

  • Profile Image
    Colegio_Hontanares
    Answered on August 05, 2021 at 08:39 AM

    Buenos días, al parecer estar anclados a nuestra página web genera bloqueos en la continuación del formulario, estamos realizando las pruebas con los links y hasta el momento todo bien.

    ¿Qué podemos hacer para corregir estos inconvenientes en la página?

    Adicional, los errores que muestran en las condiciones es extraño por que no he configurado dicha función para ese formulario.

    Quedo atenta en como puedo resolver estos errores. Gracias.

  • Profile Image
    Kevin_G
    Answered on August 05, 2021 at 04:15 PM

    Realice unas pruebas en este formulario y este es el problema que pude experimentar:

    1628193414_610c42865f879_1.gif

    Al parecer en algún punto del formulario los botones para continuar se bloquean y no permiten continuar con el formulario, te recomendaría agregar el formulario a tu página usando el método iFrame, la siguiente guía te ayudará a hacerlo: https://www.jotform.com/es/help/680-usando-el-codigo-iframe-del-formulario

    Si el problema persiste, por favor graba un video del error que puedes replicar en tu prueba, puedes subir el video a Google Drive u otro servicio de almacenamiento en la nube y compartir el enlace aquí, de esta manera podemos entender el problema exacto que experimentas.

    Respecto a las condiciones que mostré en mi captura anterior, tienes que corregir la lógica de las condiciones, desafortunadamente en este paso no podemos ayudarte porque esta lógica la implementa el dueño del formulario acorde a lo que quiere que las condiciones ejecuten, si no sabes cuál es la lógica que tienen que seguir las condiciones puedes simplemente eliminarlas para evitar conflictos e tu formulario. Encontrarás las condiciones al momento de editar tu formulario bajo la pestaña de "Ajustes" y la sección "Condiciones".



  • Profile Image
    Colegio_Hontanares
    Answered on August 12, 2021 at 12:54 PM

    Kevin muchas gracias, no te he podido adjuntar el video por que lo realizan personas externas (pero les pasa exactamente lo que a ti te sucede), cuando yo lo realizo me da perfecto... y mis compañeros también lo diligencian sin problema. Entonces no sabemos esto es que influye. Corregiré con lo que me dices y aplicaré lo de las condiciones.

    Mil gracias, te estaré contando cualquier novedad.

  • Profile Image
    Colegio_Hontanares
    Answered on November 25, 2021 at 09:07 AM

    Hola, buenos días.
    Sigo teniendo inconvenientes con ambos formularios, no sé si es por que es muy extenso o por que el formato de e-card es complejo para cargar. Las familias al finalizar de llenar el formulario manifiestan que no pueden darle clic en enviar por que se queda bloqueado.

    Les estamos enviando el link directamente del formulario, no está alojado en la página web de nosotros y los condicionales están bien. ¿Me cuentan por favor que podemos hacer?

    Agradezco la ayuda.


  • Profile Image
    Colegio_Hontanares
    Answered on November 25, 2021 at 11:35 AM

    Adjunto algunas pruebas que estamos realizando externamente:

    Pasa lo siguiente;

    • Se queda bloqueado en alguna pregunta y no deja continuar,
    • Cuando se guarda empieza desde cero y no desde donde se dejó
    • Al momento de continuar algunas preguntas se tiran hacia la derecha y no dejan leer la pregunta.

    Estamos realizando la prueba en video para adjuntarselas.

    De igual forma ustedes pueden acceder a los links :

    https://form.jotform.com/211923771878669

    https://form.jotform.com/203144342729654


    Gracias.

    1637857911_619fba77819d0_form2.jpeg1637857910_619fba76e1e8c_form3.jpeg1637857910_619fba76bb1ce_form1.jpeg

  • Profile Image
    Kevin_G
    Answered on November 25, 2021 at 12:53 PM

    Gracias por los detalles adicionales.

    Les estamos enviando el link directamente del formulario, no está alojado en la página web de nosotros y los condicionales están bien. ¿Me cuentan por favor que podemos hacer?

    ¿Puedes confirmar que el problema persiste al usar el enlace directo del formulario?

    He realizado unas pruebas con los enlaces que compartes en tu última respuesta y al parecer funcionan sin problemas, intenté acceder al enlace que se muestra en tus capturas, pero me temo que no encuentro el formulario. También ¿puedes confirmar si agregaste el formulario usando el método iFrame como fue sugerido anteriormente?

    Adicional me gustaría sugerir que elimines el código Javascript incluido en el código iFrame para verificar si el problema se debe a algún conflicto entre los códigos del formulario y la página web.

    También limpié el caché del formulario, te recomendaría realizar unas pruebas y dejarnos saber si funciona.

    Quedamos pendiente a tu respuesta.

  • Profile Image
    Colegio_Hontanares
    Answered on November 25, 2021 at 01:05 PM

    Hola.

    Confirmo que enviamos directamente el link del formulario a estas familias y nos manifiestan que no ha sido posible. Presenta el mismo inconveniente, modificamos el i frame que nos dijeron pero persiste.

    De igual forma estamos cambiando que sea un enlace directo y no que esté alojado en nuestra página, pero como dije anteriormente se les pasa el link directo del formulario y el problema continúa.

    Ya les indicamos también que limpiaran la caché manifiestan que en 3 ocasiones persiste el problema y es un formulario muy extenso.


    Podrías llenar el formulario completamente y darle enviar? No importa que se nos guarde ese registro.

    Adicional de que guardan y no continúa adjunto el video de una persona externa 1637863480_619fd03893152_formulario no g



  • Profile Image
    BDAVID
    Answered on November 25, 2021 at 07:18 PM

    Buen día, hice la prueba en ambos formularios:

    1)

    1637885418_61a025ead9825_prueba.gif

    2)

    1637885792_61a02760bd7ea_prueba2.gif

    Y se enviaron correctamente. Por favor remueva los formularios de su sitio web, he incrústelos con el código Iframe, pero sin la parte script: https://www.jotform.com/help/148-getting-the-form-iframe-code/

    Pegue el código Iframe en un notepad, y ahí verá la parte Iframe, solo incruste esa parte, y deje la propiedad de scrolling como "yes", ejemplo:

    1637885889_61a027c17841b_