problemi di connessione con zapier

  • Profile Image
    luciadb
    Asked on July 02, 2021 at 06:01 AM

    Buongiorno,

    sto cercando di creare un collegamento con zapier tra il modulo creato su jotform e webhook (mi devo collegare ad un CRM),

    questo il modulo:

    https://form.jotform.com/211803626737356

    e questo lo zap:

    https://zapier.com/shared/90e6b3172f3472322e5444353a464f249a4e3302


    mi fermo sempre al test trigger di jotform con questo errore:

    TypeError: Cannot read property 'map' of undefined

    se provo ad effettuare un nuovo test invece questa è la risposta che mi dà zapier:

    No submission found


    come posso risolvere?

    Grazie


  • Profile Image
    Marco_S
    Answered on July 02, 2021 at 10:04 AM

    Slave,

    Sta riscontrando il problema su un solo modulo, o su più moduli? Ha già utilizzato Zapier con successo su altri moduli in passato?

    Come primo passo, per accertarsi che l'integrazione con Zapier funzioni regolarmente, le consiglierei di provare a creare un semplice modulo con appena due o tre campi e provare ad aggiungere l'integrazione con Zapier su tale modulo.

    Una volta accertato che l'integrazione funziona regolarmente, possiamo passare ad effettuare ulteriori test.


    Restiamo in attesa di un gentile riscontro,

    Saluti


  • Profile Image
    luciadb
    Answered on July 02, 2021 at 11:21 AM

    Salve,

    è la prima volta che faccio il collegamento di jotform con zapier.

    ho effettuato un test come da voi indicato e continua a fermarsi al test trigger, sembra quasi che zapier non "veda" il mio account jotform.

    Potete verificare che sia tutto settato correttamente per agganciarsi a zapier?

    Questo è lo zap fatto come da vostro consiglio:

    https://zapier.com/shared/eae8ab945231d04efa3a2d799721d0a5a63006af

    e questo il modulo semplificato:

    https://form.jotform.com/211823992513356

    Mi sembra che il problema derivi proprio qualche azione non fatta su jotform per far si che zapier lo possa "vedere" ma ho bisogno di indicazioni più specifiche da voi.


    Attendo vostre,

    grazie


  • Profile Image
    Marco_S
    Answered on July 02, 2021 at 04:01 PM

    Salve,

    Sul modulo semplificato da lei indicato non risulta attiva alcuna integrazione Zapier. Potrebbe gentilmente seguire i passi spiegati in questa guida e farci sapere se riesce regolarmente ad impostare l'integrazione?

    https://www.jotform.com/blog/zapier-integration


    Grazie per la collaborazione,

    Saluti

  • Profile Image
    Marco_S
    Answered on July 02, 2021 at 04:07 PM

    Le consiglio inoltre di dare un'occhiata al seguente thread, dove il problema era legato alla località dei data center. Cambiando data center, il tutto si è risolto:

    https://www.jotform.com/fr/answers/3067613-zapier-integration-on-jotform-why-after-connecting-my-account-none-of-my-forms-get-recognized-and-i-cannot-set-the-trigger

  • Profile Image
    Marco_S
    Answered on July 02, 2021 at 04:11 PM

    Di seguito un'animazione di come effettuare il cambio, realizzata dal mio collega @Anthony:


    1625256635_60df72bb04c66_1625252466_60df

  • Profile Image
    luciadb
    Answered on July 03, 2021 at 04:32 AM

    Grazie mille,

    sembra essere tutto risolto solo spostando la località dei data center.

    Grazie per l'aiuto!