Why embedded form is not working in my webpage?

  • Steven Hannigan
    Asked on February 14, 2017 at 9:51 AM


    This message is to Welden.

    What is wrong with my page embed code ???

    When I use the code off my webpage, the page loads no problem ?

    Also, until recently...this page worked just fine ! So, I dont understand how the code has suddenly become "Wrong" ???

    The exact code works on another page on my website ! The only difference between the 2 is that the other page is in Chinese !

    Also, the above "Embed Code" button on this page is absolutely useless !


  • Kevin Support Team Lead
    Replied on February 14, 2017 at 12:46 PM

    Could you please provide us the link to the webpage where you form does not work? 

    Maybe there's a conflict between the scripts in the embedded code and the scripts in the webpage, what I would suggest you is to try embedding your form again using the iFrame code only, without the JavaScript part, it should be like this: 












    Replace the "FormID" with the ID from your form, please also let us know how it goes. 

  • Webuildwaterfalls
    Replied on February 14, 2017 at 6:54 PM

    Hi Kevin and Welden Actually, I am an idiot :) Shortly after posting that Message yesterday, I realized that the "Embed Code" in your example was a "Screenshot"! Anyway, I went back to the Jotform website and used the "IFrame" Embed Code and pasted it into my webpage. The code produced a different result this time but, all I had was a "Broken Image" Icon in the center of the page ! I went back to the Jotform site and used the "SHARE FORM" option which I had never seen before! I chose the "Dreamweaver" option and it worked ! The page seems to be fine now ! I loaded a new Image into the Form on the Jotform site and republished using the same Method and that worked ! At first...when republishing the .gif I used i got a couple strange errors. The first time, it reloaded my Original .gif Image that I had already deleted ! The second time, It loaded "LogoGif.901.gif" (Image name is actually LogoGif.gif). Finally on the 3rd attempt it loaded the correct Image! So, the method of "Share Form" - "Dreamweaver" worked for me ! You can view this at http://www.webuildwaterfalls.com/contact.html Now, strangely...the Contact form on my Chinese Contact page has stopped working ??? It was fine yesterday ??? So, if you go to that page http://www.webuildwaterfalls.com/contact_chinese.html you can see the exact result of what was "NotWorking" previously ! The only difference being is that the page contents are in Chinese ! I am not sure if republishing my page had anything to do with it but, the Identifier Number is the same so, not sure why it should have stopped working ??? As far as the "Script Error" you mentioned in there being a conflict you may be right ! I noticed when I added the "New Code" (which is Working), Dreamweaver reports a script error in my "Code View" and Dreamweaver is trying to hang when I open this page and taking an unusually long time to reflect any changes when I add the Code or try to Edit on this page ! The Script Eror though is not in the "JotForm Code" it is another piece of short .js code inside my "Head" tag ??? I am useless with code so I dont have a clue ? I havent changed anything except added the "JotForm Code" to the page (the code is extremely long). I am going to later create a new Contact page to play around with and see what happens! I dont want to mess with my current Contact page right now because at least its working ! If you check it out please let me know your findings ! I will keep you posted if I discover anything ! As I mentioned, the problems seemed to have begun when Jotform created a new version ! I am not sure when the problems arose exactly as I just discovered it accidentally last week ! Thanks Steve www.webuildwaterfalls.com

  • Webuildwaterfalls
    Replied on February 14, 2017 at 8:22 PM


    Well, just as I thought !

    There is no problem with my Form or my pages other than its NOT WORKING here in China !

    Whoever posts this Great Wall of China Blocking or whatever it is ...Sorry, you're wrong !

    I dont know where you get that information or how you go about Testing it or where you are actually located ???

    I am in the heart of china (Shenzen to be exact)  and my Internet is through China Mobile !

    As soon as I turn on a VPN, everything is fine !

    So, the problem is China or the Internet Provider but, its definitely unique to China !

    I just recently switched my Service Provider to this company and that may be the problem !

    There are multiple issues without the VPN and it comes from different sources here in China - Not just mine !

    Captcha Codes dont display or dont work !

    Line limit submissions dont function properly and Forms often just wont display !

    Other Issues include the Form Submission not sending ! 

    After Form Submission will get "Jotform website took too long to respond" along with "DNS Sever not Available"!

    So, This all becomes a major nightmare that I dont have time for !

    The Form works in North American instances and thats all thats important for the moment !

    I will simply find a solution for the Chinese Form Filler Outers :)


    Thanks everyone for any help !

    Unless you are actually based in China and can replicate the exact circumstances, there is no point !