Form not integrating to Salesforce

  • Profile Image
    tshaver
    Asked on December 07, 2016 at 01:00 PM

    I have created forms in the past and had trouble with integrating but they magically seemed to work after some configuring and time... 

     

    I just created a new form - and I am wondering if you guys can see any issues with the logic as to why the info wont go into salesforce. The form is the Starter Company Plus Application. I have aligned up all the salesforce fields (ie. for every jotform field, there is a lead field) - Im wondering If possibly an issue is Jotform radio button to Salesforce picklist is causing a problem?

     

    I feel like I followed all the rules but it doesn't work. Any help would be appreciated. thanks!

    Form https://form.jotform.com/63365184965972

  • Profile Image
    Kiran
    Answered on December 07, 2016 at 03:22 PM

    I have tried to access the Salesforce integration on your form to see the mapping fields and it seems that there is an issue with the integration.

    Could you check and correct the information to authenticate your Salesforce account in the form?

    Please get back to us if the issue still persists. We will be happy to assist you further. 

  • Profile Image
    tshaver
    Answered on December 07, 2016 at 03:26 PM

    It is fine on my end. All is authenticated. All the fields have checkmarks besides them but no info is being transmitted to salesforce. 

  • Profile Image
    Kiran
    Answered on December 07, 2016 at 05:10 PM

    I have tried integrating Salesforce to the cloned version of your JotForm. However, I have few fields including a picklist custom field to the integration. When the form is submitted, I have received the form submission to the Salesforce without any issue.

    Since there are several custom fields mapped with the form, could you try removing a set of fields in the mapping to isolate the issue?

    Let us know if you need any further assistance. We will be happy to assist.  

  • Profile Image
    tshaver
    Answered on December 08, 2016 at 09:05 AM

    I only integrated the required fields for salesforce (ie name, date, lead status, lead source, newsletter). 

     

    Nothing went through. 

  • Profile Image
    candy
    Answered on December 08, 2016 at 10:08 AM

    Hello,

    I have checked your Salesforce integration from your account. I have seen that some of the fields of the integration matched wrong as you can see the screenshots of the configuration below:

    This is the reason why your Salesforce integration does not work properly. Even if, one of the form fields does not match your Salesforce fields, your integration can not work properly.

    Please check again. Try to fix the fields of the integration.

    If the issue still persists, let us know.

    Thanks in advance.

  • Profile Image
    tshaver
    Answered on December 08, 2016 at 10:37 AM

    What do you mean matched wrong? They are matched correctly to me? Do you mean question/field type? ie radio to dropdown?

  • Profile Image
    Kiran
    Answered on December 08, 2016 at 10:46 AM

    Yes. A mismatched field type could also cause the issue. Also, could you let us know the Salesforce edition that you are using? Please be noted that it is required to have the API access enabled for your Salesforce account. However, the API access in the Salesforce is available with only a few editions as mentioned in the Salesforce article below:

    https://help.salesforce.com/HTViewSolution?id=000005140

    Please make sure that you are having one of these editions and let us know if the issue still persists. We will be happy to assist you further. 

  • Profile Image
    tshaver
    Answered on December 08, 2016 at 11:37 AM

    We have professional but have API. 

     

    We have other forms we use that are going into Salesforce so that should not be the issue. 

     

    And the field types are radio button to dropdown if anything - and it seems to work on other forms and other people from Jotform said they should integrate. .... so..

  • Profile Image
    Kevin_G
    Answered on December 08, 2016 at 12:31 PM

    I have checked on the SalesForce documentation and found this article where they explain it is possible to get API access even on Group and Professional editions, but there are still some limitations: https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/dev_packages_api_access.htm 

    Now as far as I know it is recommended to use the same field types in your form and SalesForce account, otherwise the data may not be properly passed. 

    Another option would be to reset your security token, with a fresh token it may work too, here's a link that will help with that: https://help.salesforce.com/articleView?id=user_security_token.htm&language=en_US&type=0 

    Also, try sending different records since if there are duplicates may be that they are not being added or are updating existing records. 

    Do let us know how it goes.