Form Tabs Widget is not working in my form

  • Profile Image
    djflorence
    Asked on December 15, 2016 at 09:23 AM

    I have the tab widget and it visually loads but I can not select a tab for a long time.  It is happening on several forms.

     

    Thanks

  • Profile Image
    olivia
    Answered on December 15, 2016 at 09:36 AM

    Hi,

    Load time is depends on your form length. If your form is long and has a lot of conditions, this is normal. However, I have checked your form and it is seen that there is a problem about your conditions and Form Tabs Widget. Tabs are disable and your conditions may cause this.

    According to my investigation, you have many conditions (85) on your form and some of them has missing form fields. In addition, your form is also a long form.

    Could you please give me some time to check on your conditions and form fields?

    I'll back to you as soon as possible.

    Thank you.

  • Profile Image
    djflorence
    Answered on December 15, 2016 at 09:39 AM

    Thanks, it was working earlier today.

  • Profile Image
    djflorence
    Answered on December 15, 2016 at 09:46 AM

    If it helps I have a clone of the same form and the same thing is happening.  However I have completely different forms that do not seem to be affected.  I tried to remove the tabs widget on the clone thinking that was the issue but the dynamic fields were still not working.

     

    Thanks

  • Profile Image
    olivia
    Answered on December 15, 2016 at 09:49 AM

    Hi,

    Thank you for your additional information.

    I have cloned your form to my side and I'm working on it now. I have also checked our Form Tabs Widget if there is a problem on it or not but it is working fine.

    However, you can try narrow your form and re-add your Form Tabs Widget to your form.

    I'll back to you as soon as possible.

    Thank you for your understanding.

  • Profile Image
    olivia
    Answered on December 15, 2016 at 06:14 PM

    Hi,

    I have checked your form in the link: https://form.jotform.com/djflorence/Order_System

    Your form and Form Tabs Widget are working fine. They are clickable now. However, loading of tabs takes a long time again.

    I have made more investigation on your form, too.

    There are different reasons why loading of your form (52084089174156) takes a long time.

    1- You have approximately 40 widgets in your form.

    2- You have 85 conditions in your form. Some of these conditions has missing form fields.

    3- Your form is already very long.

    Therefore, it is so normal that your form does not load quickly.

    Please note that internet connection speed is also very important issue for you. You need to think all of your users and their internet connection; therefore, you need to minimalize of your form if you want to load your form so quickly.

    I have also made some changes on your form. I have disabled some of your conditions that has missing form fields. Please clear your missing form fields from the conditions. Please have a look at the following video:

    This is my demo form: https://form.jotform.com/63496758972982

    You can clone my form to your side too. Please have a look at the guide about it: How-to-Clone-an-Existing-Form-from-a-URL

     

    If you need any further assistance, please feel free to let us know.

    Thank you.