What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Tabs widget: part of the widget scripts are showing up instead of the actual form tabs

    Asked by fhpw on December 31, 2016 at 04:07 PM

    Recently I created my an application form. Everything was done except adding the form tabs for the multi-page form. I thought this would be easy, but when I added the Widget, it ruined my form.  Unbelievably, all the form fields were  completely rearranged. Not a problem, I went to reverse the form from History; yet, shockingly, there were not versions available except from two days prior - meaning all the customization was gone and I am left with a mess.  I could not figure out what went wrong. The form is built using V4.

    Here is a link to the form that was rearranged > https://www.jotform.com/v4/63626136361959.

    Can you recover the most recent version. Below is what it should look like.

    Fortunately, I had made a clone (not entirely complete with all changes but close). This is what it should look like >

    https://www.jotform.com/v4/63650166856968

     

    I decided to do a test form.  I know - not having worked in the past with the Form Widget, I should have done this first. So, to my surprise it happened again and then just coding is showing. Clearly, there is something I am missing.

     

    Test Form Link > https://www.jotform.com/v4/63654746914971

    is the problem due to the V4 Build? Or, is there something I need to do differently.  I am thinking that it might be the V4 because I cannot get the Progress Bar Widget to work or Forms Upload Widget will intermittently show the preview. 

    I have not had a problem working with Widgets using the older build version.

    I appreciate the assistance in helping to resolve the issue.

     

  • Profile Image
    JotForm Support

    Answered by Welvin on January 01, 2017 at 06:29 AM

    Our apologies for the troubles and inconveniences. 

    I can replicate the problem with the Form Tabs widget. It is showing fine in the form builder, but not in the preview as you outlined. Here's my test form https://form.jotform.com/70002856934960.

    I don't see any error while building the form, but I am sure there's something in the v4 builder that's causing this. 

    I have created a ticket for this matter and forwarded it to our developers. If there are updates, you should know it through this thread. Unfortunately, I don't see any logs either from your Revision History so I'm afraid I can't fix it for you this time. I will note it on the ticket. 

    For the meantime, I would suggest going back to the version 3 of the form builder. Simply go to My Account - Settings page (https://www.jotform.com/myaccount/settings) and select v3:

  • Profile Image
    JotForm Developer

    Answered by ceren on January 02, 2017 at 09:48 AM

    Hello fhpw,

    We're sorry the inconveniences. Form Tabs widget is fixed now.

    Unfortunately, you need to re-add the widget to your form.

     

    If you have any other questions please let us know.

  • Profile Image

    Answered by fhpw on January 03, 2017 at 07:25 PM

    Thank you.