What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Autoresponder Email: Hide Empty Fields not working on edited template

    Asked by vermontweddings on January 06, 2017 at 11:35 AM

    I just tested the Email Autoresponders I have set up and they are not working as I hoped.

    I have turned on the bit for Hide Empty Fields in the Email Notification and when I complete a form, the email sent DOES show the empty fields in email form but in the PDF the empty fields are not there. So it seems that the setting is set only for the PDF version and not the email version of the autoresponder.

    I want to be able to send a copy of the completed form to the submitter but I have conditions set depending on what they answer. Now, the email that sends shows all the options that they did not see on the form as a result of the conditions. It makes the autoresponder email extremely confusing to the recipient.

     

    Please help!

     

    Page URL:
    https://form.jotform.com/63545084223150

    Screenshot
  • Profile Image
    JotForm Support

    Answered by Charlie on January 06, 2017 at 01:02 PM

    Hi,

    I'm sorry for the inconvenience. Unfortunately, the "Hide Empty Fields" on the email autoresponder only works on the default data table and template:

     

    If you make any edits inside the email template, the functionality of the "Hide Empty Fields" will no longer work. In your case, you added a text paragraph inside it which caused the issue. You can test this out by creating a new autoresponder without any edits on it, enable the Hide Empty Fields there and you'll see that it works there.

    Let us know if you need further help on this.

  • Profile Image

    Answered by vermontweddings on January 06, 2017 at 01:07 PM

    If I add the text outside of the template but still in the email, would it then work? I would love to be able to add a message at the beginning and end of the template.

    Thanks,

     

  • Profile Image

    Answered by vermontweddings on January 06, 2017 at 01:46 PM

    Okay...I made a new autoresponder without adding any text before, after or in the template frame and it still displays the unanswered fields. so, creating a new autoresponder without any edits on it, enabling the Hide Empty Fields does not work.

    Help. Please.

     

  • Profile Image
    JotForm Support

    Answered by BJoanna on January 06, 2017 at 03:39 PM

    I have cloned your form and I added new Autoresponder email. After that I have tested my form, but I was not able to replicate mentioned issue. Empty fields were not shown inside of my new Autoresponder email. 

    Can you please try again to add new Autoresponder email.

    Also here is my cloned form: https://form.jotform.com/70056255914960 

    Feel free to test it and clone it. 

    If the issue still persist on your end after adding new Autoreponder email, please let us know.

  • Profile Image

    Answered by vermontweddings on January 09, 2017 at 12:10 PM

    That's awesome! However, when I tried to do it, I was not successful. I cloned the form, deleted all other emails and added the autoresponder and the notification emails. I did not touch anything on them except for on the autoresponder, I changed the field for who the email should go to to be the registrant's email address (it was defaulting to an inaccurate field).

    The notification email worked but the Autoresponder email did not work. Confusing. Please help.

  • Profile Image

    Answered by vermontweddings on January 09, 2017 at 01:20 PM

    Hi Again. I was wondering on your clone of my form, when you added the Augoresponder Email, did you see that the email recipient was not an email address and that you had to change it to make it be the correct field? I wonder if that has anything to do with it not working on the Autoresponder but working for the Email notification?

     

  • Profile Image
    JotForm Support

    Answered by BJoanna on January 09, 2017 at 01:29 PM

    I did noticed that incorrect field is set as email field. However that was not causing mentioned issue. 

    It seems that inside of our old wizard hide empty field option was set to disabled inside of your form. Because of that empty field were shown inside of your Autoresponder email. 

    I have logged into your account and I have set mentioned option to Enable. Empty fields should now be hidden inside of your Autoresponder email. 

    Please test your form again.

    Hope this will help. Let us know if you need further assistance.