How do I upgrade to version 4.0?