Turkish Character Issue - ö

  • Profile Image
    avonsayac
    Asked on June 11, 2012 at 11:21 AM

    I had given to my text area validation as alphabetic. When I was testing my form locally I got an error that the word should be alphabetic. Please check attached screenshot.

  • Profile Image
    idarktech
    Answered on June 11, 2012 at 06:56 PM

    Hi,

    That's actually the expected functionality of alphabetic validation by default, it doesn't accept non-english characters. However, you can modify that by downloading your form's full source code. After that, open the js folder that's included in your form files and replace jotform.js file to this: jotform.js (right click >> save link as)

    You can try it with this form: http://idarktech.com/test/regex_test/test_custom_regex.html

    Hope this helps. Let me know if you have further questions. Thank you!

  • Profile Image
    avonsayac
    Answered on June 12, 2012 at 02:32 AM

    Hi idarktech I still get error in the link you send

    (http://idarktech.com/test/regex_test/test_custom_regex.html)

     

    Can you please check the screenshot here = http://prntscr.com/agw69

  • Profile Image
    idarktech
    Answered on June 12, 2012 at 02:48 AM

    Hi,

    Thanks for your reply.

    I think some turkish characters aren't declared, it's limited by the way. I'll update you with this, I'll be right back.

    --

    Upd: Can you please check now? Be sure to clear your browser's cache first. I have already added some of the turkish characters.

    Let me know if there's any problem. Thanks!

  • Profile Image
    avonsayac
    Answered on June 12, 2012 at 06:02 AM

    This time it worked, will use the js file now.

     

    Thank you