Why translated fields are not showing properly?

  • Profile Image
    alexfes
    Asked on February 14, 2017 at 01:29 AM

    This is what I want to translate (in table format):

    I have input all the translation in the translation page and saved:

    But still the form preview still show in english. 

     

    Thanks for your help.

  • Profile Image
    Nik_C
    Answered on February 14, 2017 at 04:51 AM

    I checked some of your entries, but it looks like they are not saved:

    I did some further tests on a clone version of your form to see if the translated fields are saving their values, and it worked for me:

    Could you please test and try to translate some of your fields and see if the issue persists?

    We'll wait for your response.

    Thank you!

  • Profile Image
    alexfes
    Answered on February 14, 2017 at 10:17 PM

    Cuz the project is quite urgent so I have build another one to use first. The link shld be this one: https://form.jotform.me/alexfes/mock-inetrview-form-translation  
    Sorry for any inconvenience 

  • Profile Image
    Nik_C
    Answered on February 15, 2017 at 12:59 AM

    I checked your new form and it looks fine to me, although I don't know Chinese :)

    But all fields are translating, that I can confirm.

    If you need any further questions do not hesitate to contact us.

    Cheers!

  • Profile Image
    alexfes
    Answered on February 15, 2017 at 03:59 AM

    Still have problem on this translation

  • Profile Image
    liyam
    Answered on February 15, 2017 at 05:39 AM

    Hello,

    Can you try modifying some form fields and then modifying some translations right after? Looks like the form when editing the translation is stuck somewhere. I will also do some tests if this is form specific or if this can happen to all forms.

    Thanks.