Field name tag is not working in "Text" field.

  • Profile Image
    IanRm
    Asked on February 17, 2017 at 06:12 AM

    I am using the text element with the {field name} function to create my own syntax and it has been working well - but two of them aren't working - you will see what I mean when you look at my form  https://eu.jotform.com/build/70404452046952

    The two fields that are not displaying the content of the field like the others are {CustFirstTag} and {headerNotes}

    I brought this up in a previous thread but have created a new thread as this is a new issue - (https://www.jotform.com/answers/1068320-JotForm-V4-not-showing-the-edits-done-on-preview-#3) the person in the previous thread understandably misunderstood me to be talking about my email notification - however I am talking about the text within my form. 

    Might you have any advice as to how I can fix this? I have a feeling it might be to do with me changing the Title of the field within the form, which then seemed to automatically change the field name - which I then tried to change in the text but with no luck!

    Thanks for your help

  • Profile Image
    ashwin_d
    Answered on February 17, 2017 at 07:57 AM

    Hello IanRm,

    I'm sorry for the trouble caused to you. 

    I am not sure what was causing this issue. I cloned your form, deleted both the fields, added them again and that seems to have solved the problem. I added the correct field name in the text field.

    Please take a look at the following cloned form and see if this works as expected:  https://form.jotform.com/70473623042954

    Feel free to clone this form in your account. The following guide should help you in form cloning:  https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    Thank you!

  • Profile Image
    IanRm
    Answered on February 24, 2017 at 12:49 PM

    Hello It seems this problem is back - this time I have 4 new text fields (with single hashtags as the content) - you will see them towards the bottom of my form in one line) which I would like to place in my syntax (with the intention of disabling these fields in certain scenarios) However the syntax doesn't seem to be registering them as there when I preview -

     

    I have them nested directly beside another field (i.e. with no space in between) like this: 

    {doubleclickTo23}{CustFirstTag17}

    {pp}{customerSurname}

    {pp25}{organisationTag}

     {pp26}{otherTag}

    The first field in the samples below are the fields that are not displaying

     

    Here is the link to the current version I am working on:

    https://form.jotform.com/70544647605964

     

    Thank you

  • Profile Image
    Jim_R
    Answered on February 24, 2017 at 01:54 PM

    Hello, I tested that same form you linked https://www.jotform.com/70544647605964 but failed to see any Field Names not populating on your Text (HTML) Field.

    Here's how I saw it from my perspective:

    I can only assume you figured it out after posting your question. But if I missed a field, kindly get back to us with a list of all the FieldNames not working so we can have a closer look.

  • Profile Image
    IanRm
    Answered on February 24, 2017 at 02:18 PM

    Hello the fields that are missing are actually the four text fields at the botom of the field that all have an individual # in it. These are the ones that are not showing up in preview. (there should be a hash before each of the tag fields. The problem seems to be still persisting for me currently.

  • Profile Image
    Jim_R
    Answered on February 24, 2017 at 03:01 PM

    Ah my bad, thanks for clearing that up 😉

    I checked a cloned copy of your form but failed to see any Field Names entered on those 4 Text (HTML) Fields with prefixed hashtags (they just contain a hashtag and that's it).

    I also checked the list of Field Names you originally sent:

    {doubleclickTo23}{CustFirstTag17}

    {pp}{customerSurname}

    {pp25}{organisationTag}

    {pp26}{otherTag}

    ...and when I compared it with all the fields you have on the form, the firsts of all the pairs are not there:

    {doubleclickTo23}

    {pp}

    {pp25}

    {pp26}

    The 4 above are not in your form thus explaining why the FieldNames are not doing anything. To compare, here's the list of all the FieldNames present on your form at this time:

    Can you give us the exact FieldNames you want to populate on the 4 Text Fields at the bottom so we can do further tests?