What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Again, my form is not refreshing on my site when I make updates in the JF editor

    Asked by chrisjaeger on June 15, 2012 at 12:14 PM

    Again... my form is not updating on my site based on the changes I am making in the JotForm editor. 

     

    http://www.marketingtobridesonline.com/

     

    Top right column of all pages.

     

    I'm embedding the code, the new form attributes are not showing up on my site (Wordpress).

     

    I never had these problems before that big glitch you had with your domain awhile back.

     

    Chris

     

    Page URL:
    http://www.marketingtobridesonline.com/

    site new form JotForm domain not updating
  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 12:32 PM

    My form in JotForm has a pale red background. Red text labels. That's not what is showing up.

    The form in my account is labeled: Marketing to Brides Top Right Inquiry Form

    In other words, the form edits I'm making, and then embedding with the embedding code, are not showing up.

     

     

  • Profile Image

    Answered by ItalyTech on June 15, 2012 at 12:32 PM

    Hi, I've checked your form and site too.

    Your form appears to be updated.

    Please try to embed it with iframe method and let us know if it solve your problem.

    Thanks.

  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 12:40 PM

    You are incorrect.

    For the purposes of figuring this out I made the background of my form pale red.

    I just went down the hall to someone else's office, a different computer, and the form is not showing up correctly.

    I should be able to use the embed code and have before successfully (not the iFrame) method.

    Something is wrong on your side.

  • Profile Image

    Answered by TrafficDivision on June 15, 2012 at 12:45 PM

    Hello there,

    I hope I can write here because I have the same problem. When I make any update to my current form and I open it in the preview, it appears okay but when I open it in a new window/tab or other browser it is not updated. I even tried private/incognito windows (Safari/Chrome) and no result. The only solution I have found yet is to copy the form and delete the older version but that takes lots of time when you need to edit more often. Can you please look at it?

    EDIT: I use your website for submissions.

    Thanks in advance,
    Mark 

  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 12:46 PM

    See: http://www.marketingtobridesonline.com/wp-content/uploads/2012/06/embed-not-working-june-2012.jpg

    This is a tremendous waste of my time!

  • Profile Image

    Answered by ItalyTech on June 15, 2012 at 12:46 PM

    I understand your request. I elevate this thread to our 2nd Support Level.

    We let you know soon as possible.

    Thanks for your patience.

  • Profile Image

    Answered by pinoytech on June 15, 2012 at 12:54 PM

    Hi,

    Sorry for the inconvenience that may have caused you today. I have checked your website were you embed your form code and I don't see any problem. I do see the updated form in my end. Please take a look screenshot of your form here. Can you please delete your browsing cache and cookies to see the changes of your form.

    Thank you!

  • Profile Image

    Answered by pinoytech on June 15, 2012 at 01:37 PM

    In addition to my answer above, can you please change http://form.jotformpro.com/ to http://www.jotformpro.com/ on your form code that you embed into your website.

    Thank you!

  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 02:24 PM

    Will do - but that's the code YOUR system gave me.

  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 02:26 PM

    Made this change and it worked. The form is rendering as it does in the editor. And updates show up immediately. There is something wrong with this on your side of this. 


    Again, the embed code I was using was DIRECTLY from your editor/editing system.

  • Profile Image

    Answered by pinoytech on June 15, 2012 at 02:35 PM

    Good to hear that your form is working properly. If you need further assistance, feel free to contact us again anytime.

    Thank you for using JotForm!

  • Profile Image

    Answered by chrisjaeger on June 15, 2012 at 02:40 PM

    If the embed code your system generates, and I'm supposed to use, doesn't work - you should fix that problem, no?

  • Profile Image

    Answered by ItalyTech on June 15, 2012 at 02:42 PM

    Sure, our developer are at work for that.

    Please use solution saied by my collegue for the moment.

    Thanks to use JotForm.

  • Profile Image

    Answered by Gregmach on September 09, 2012 at 11:06 PM

    I just have to say, after reading this post, I just started having the same problem where my form would not update to the website (cache was deleted) and my form code was http://form.jotformpro.com/ and not http://www.jotformpro.com/ so when I changed it to www.form instead of form. it works fine and updates. Glad I read this post

  • Profile Image
    JotForm Support

    Answered by idarktech on September 09, 2012 at 11:59 PM

    @Gredmach

    Glad to hear your were able to figure it out. There is a replication delay problem with some of our domains and hopefully our team will be able to fixed it as quickly as possible.

    Apologies for the inconveniences caused.

  • Profile Image

    Answered by revolutionwed on January 12, 2015 at 12:57 AM

    I've got my JotForms on my WordPress Site http://www.r3volutionweddings.com via shortcodes so it's not really possible to add a "www." I've cleared my cache bla blah...the updates are not showing up live on my site.

    On the bright side, chrisjaeger, you just gained a new subscriber. Just signed up for your free report + private facebook group!

    Going crazy with these forms not refreshing--Help!

  • Profile Image
    JotForm Support

    Answered by ashwin_d on January 12, 2015 at 02:54 AM

    Hello revolutionwed,

    This is a very old thread. I have moved your question to a new thread and you will be answered here:  http://www.jotform.com/answers/494291 

    Thank you!