delay in form update

  • Profile Image
    BAI
    Asked on June 18, 2012 at 06:16 AM

    Recently the form is not updated online, it take a few hours - after we embed form to our web site...

    Is there anything changed? We are using the Jotform a few months without any problem.

    Thanks a lot

     

    Libor Supich

    supich@bluearrow.cz

  • Profile Image
    ItalyTech
    Answered on June 18, 2012 at 06:22 AM

    Hi, can you try to change embed code ?

    simply replace:

    <script type="text/javascript" src="http://form.jotformeu.com/jsform/21692068381356"></script>

    to:

    <script type="text/javascript" src="http://www.jotformeu.com/jsform/21692068381356"></script>

     

    Let us know if this solve your problem. Thanks.

  • Profile Image
    squadhousemedia
    Answered on June 18, 2012 at 07:28 AM

    Well it´s the same with my form. I download the whole source file with css and js and after that i update some stuff online, download it again and it still looks the same.

    Not good...

  • Profile Image
    idarktech
    Answered on June 18, 2012 at 08:08 AM

    @squadhousemedia,

    Apologies for the inconvenience. 

    Can you please provide to us the website URL where you've embedded your form? This would help us investigate this issue further. Thank you so much!

  • Profile Image
    squadhousemedia
    Answered on June 18, 2012 at 08:27 AM

    I´m sorry but i currently host in on my localhost. I don´t embed the code, i download it (with css & js) so it does´t update the source code...

    caching problems?

  • Profile Image
    idarktech
    Answered on June 18, 2012 at 08:43 AM

    Thanks for your fast reply.

    Sorry though as I don't see any problems with your form, can you please point to us the exact problem or give us the form ID where this problem is occuring? Your form seems to be fine here.

    Also, I just cleared your form cache, can you retake again your form's full source code? Be sure to check first your forms and see if there are outdated parts. If there's nothing wrong then get your form's full source code and compare it to your forms here in JotForm. Report to us if you've found any mistakes.

    Thanks!

  • Profile Image
    squadhousemedia
    Answered on June 18, 2012 at 09:33 AM

    Thank you for your answer.

    This is my form url: http://form.jotformeu.com/form/21642234940347 - looks great!

    I have changed the style / layout of the form (e.g. font-size, font-family...)

    Now i go to: "Embed form wizard" - "Source" - and click on the "You can also download a compressed and refined version with seperate .css and .js files from here." link. Now i download a html-file and the css and javascript files.

    When i open the html file in my browser, i have a different style (font-size, font-family...) than in the online preview.

  • Profile Image
    idarktech
    Answered on June 18, 2012 at 10:36 AM

    I was able to replicate the said problem. Thanks for pointing it out.

    I think the problem here is the "nova theme" file where it was generated in the wrong folder path when download your form's full source code. To fix it, open the CSS folder (it's included when you download your form's full source code) and look for "nova" css file and then move it to styles folder.

    Let me know if this doesn't help. Thank you!

  • Profile Image
    captiva
    Answered on February 11, 2013 at 02:39 PM

    I had this same issue and changed the subdomain from form to www and it worked for updating it. Is this something we will have to manually do for every form if we want updates to be reflected in our pages or are you working on a solution for it? 

  • Profile Image
    Goldo
    Answered on February 11, 2013 at 02:47 PM

    The form.jotform should automatically update itself but a slight delay maybe present. My advise would be to manually switch to www.jotform and do this to every form to avoid the delay.

    It make take time if you have lots of forms but it's worth it. Thanks!

  • Profile Image
    captiva
    Answered on February 11, 2013 at 02:48 PM

    Thanks Goldo. Is this something you will be changing in functionality at some point, so the manual process is not required? 

  • Profile Image
    Goldo
    Answered on February 11, 2013 at 02:52 PM

    No worries. Yes, pretty sure developers are looking into this.