I used Gmail SMTP but it's not working in my form

  • Profile Image
    vim00010
    Asked on March 06, 2017 at 07:47 AM

    I have spent ages trying to get this working and also emailed support and i am getting no where. 

    I need to set this up so that it works on all of our forms. 

     

    I have created a gmail account especially for this, and i am using:

     

    Gmail SMTP server address: smtp.gmail.com Gmail SMTP user name: Your full Gmail address (e.g. example@gmail.com)
    Gmail SMTP password: Your Gmail password Gmail SMTP port (TLS)587 Gmail SMTP port (SSL)465 Gmail SMTP TLS/SSL required: yes

    I have tried SSL AND TLS and both still send from noreply@jotform

     

    I would really appreciate some proper support on this issue, as I do not understand why this doesnt work. And I have gone through all the existing faq pages on this topic already. 

  • Profile Image
    Welvin
    Answered on March 06, 2017 at 10:25 AM

    How about your Less Secure App settings? Did you turn it on? We have this guide for using Gmail SMTP: https://www.jotform.com/help/392-How-to-Use-Your-Gmail-Account-as-Your-Email-Sender-via-SMTP.

    If you've done the less secure apps and have the correct SMTP details, it should work. 

    Also, after you setup the SMTP, you should select the custom email in the form email settings. I see that you are still using noreply@jotform.com.

  • Profile Image
    vim00010
    Answered on March 06, 2017 at 10:28 AM

    How about your Less Secure App settings? Did you turn it on? We have this guide for using Gmail SMTP: https://www.jotform.com/help/392-How-to-Use-Your-Gmail-Account-as-Your-Email-Sender-via-SMTP.

    If you've done the less secure apps and have the correct SMTP details, it should work. -- I don't know what you mean by less secure?? Can you explain this properly please. 

    Also, after you setup the SMTP, you should select the custom email in the form email settings. I see that you are still using noreply@jotform.comYes obviously, i turned it back off as it wasn't working. I used the sender email field to set it up in the first place. 

  • Profile Image
    vim00010
    Answered on March 06, 2017 at 10:36 AM

  • Profile Image
    vim00010
    Answered on March 06, 2017 at 10:38 AM

    Your system now wont let me post the rest of the screenshots. 

    I have done what you asked above with the less secure apps.

    It doesnt work 

  • Profile Image
    vim00010
    Answered on March 06, 2017 at 10:44 AM

  • Profile Image
    david
    Answered on March 06, 2017 at 12:35 PM

    I tested the following settings with my own form and the email are sending:

    Hostname smtp.gmail.com
    Port 587
    Username Gmail Address
    Password Gmail Password
    Security Protocol TLS

    After setting up the SMTP address, I changed the sender email for my notification to that email.  Emails sent via SMTP without issue. 

    I see several test emails in your account but none attempted to send from your SMTP address.  The test emails will always be send to the default account address.  Once you change to the SMTP address, send a submission through the form to test.