What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    When clicking finish on the last step of our form the "please wait" button is getting cut off

    Asked by brett_brandsnob on March 08, 2017 at 01:11 AM

    when you click finish, "please wait" appears above the finish button, but is cut off. Please see attachment.

     

    Can you please help with this?

     

    Also, is there any option for a spinner to pop up instead of the please wait? If not, the main concern is fixing the cut off

     

    Thank you

     

     

  • Profile Image
    JotForm Support

    Answered by John_Benson on March 08, 2017 at 03:08 AM

    Hello, we had a temporary issue with the server or CDN but it was fixed immediately. This is the reason the submit button was stuck in the "Please wait" button. 

    I did a test submission to your form and I was able to submit it without issue. See image below:

    Please try it again and if the issue persists, let us know so we can investigate it further. Thank you.

  • Profile Image

    Answered by Brett   on March 08, 2017 at 03:14 AM

    hi John, 

     

    my issue was not that the "please wait" was getting stuck. I understand that there was a server issue earlier, but what I mean is if you look at the attachment above your response you'll see that the words "please wait" are not on the button and as you can see the word "wait" is cut completely in half. 

     

    I would like to have it fit fully on the button as it is meant to be

     

    thank you very much 

  • Profile Image
    JotForm Support

    Answered by John_Benson on March 08, 2017 at 04:31 AM

    My sincerest apologies, Brett.

    You need to increase the width of the Submit button in order to display the "Please wait" text properly. Here's how:

    1. Open your form and click the Form Designer button. It is located on below the Account User icon. 

    2. Scroll down and Open the Advanced Designer by clicking the button. 

    3. Select the Submit button field and change the button width to 190px

    Hope that helps. If you need further assistance, please let us know. We'll be happy to help you.

    Thank you.

  • Profile Image

    Answered by brett_brandsnob on March 09, 2017 at 10:23 AM
    Answered by *Brett *on March 08, 2017 at 03:14 AM
    hi John,
    my issue was not that the "please wait" was getting stuck. I understand
    that there was a server issue earlier, but what I mean is if you look at
    the attachment above your response you'll see that the words "please wait"
    are not on the button and as you can see the word "wait" is cut completely
    in half.
    I would like to have it fit fully on the button as it is meant to be
    thank you very much
    ...
  • Profile Image

    Answered by brett_brandsnob on March 09, 2017 at 10:26 AM
    Answered by *Brett *on March 08, 2017 at 03:14 AM
    hi John,
    my issue was not that the "please wait" was getting stuck. I understand
    that there was a server issue earlier, but what I mean is if you look at
    the attachment above your response you'll see that the words "please wait"
    are not on the button and as you can see the word "wait" is cut completely
    in half.
    I would like to have it fit fully on the button as it is meant to be
    thank you very much
    ...
  • Profile Image

    Answered by brett_brandsnob on March 09, 2017 at 10:32 AM
    Answered by *Brett *on March 08, 2017 at 03:14 AM
    hi John,
    my issue was not that the "please wait" was getting stuck. I understand
    that there was a server issue earlier, but what I mean is if you look at
    the attachment above your response you'll see that the words "please wait"
    are not on the button and as you can see the word "wait" is cut completely
    in half.
    I would like to have it fit fully on the button as it is meant to be
    thank you very much
    ...