Translation: Setting a different language as the primary isn't working

  • Profile Image
    partnerships
    Asked on March 09, 2017 at 09:22 AM

    Hi there,

    I think this feature might not have rolled over to V4. I tried setting Spanish as the default language, but it won't default to that when I visit the form. I tried clearing my cache and visiting the form in incognito mode as well. Screenshot attached here

    Thank you!

  • Profile Image
    EltonCris
    Answered on March 09, 2017 at 02:30 PM

    Thanks for reporting. I was able to reproduce the problem.

    https://www.jotform.com/70674949642974 (Spanish is set as primary yet it keeps showing English as default)

    I have now raised this to our developers for further investigation. We'll let you know once this is fixed.

  • Profile Image
    partnerships
    Answered on March 15, 2017 at 06:46 PM
    Hi Elton,
    I just wanted to follow up on this as we'd like to start sharing this form
    in one of our new markets. Thank you!

    *WeWork | Tom Vasiliu*
    Manager, Business Development
    M: 305.928.5227 <3059285227>
    we.co
    Create Your Life's Work
    ...
  • Profile Image
    liyam
    Answered on March 15, 2017 at 11:04 PM

    Hello,

    Unfortunately we still have no updates on this matter. But this is already assigned to a developer and is marked as important. We'll keep you posted once we have updates.

    Thanks.

  • Profile Image
    hasan
    Answered on March 30, 2017 at 01:33 AM

    Hello,

    I'm sorry for the late answer. The thing is, we hid some of the options of Form Languages to keep UI simpler. One of them was the "Detect Language" option, which tries to detect form's language based on browser settings and is enabled by default. That why you are seeing your form in English all the time.

    Now we've re-enabled that option in our UI. You can disable it to open your form in your preferred language. Please try to disable it and let us know if you have any problems.

    Have a nice day.