Jotform getting stuck on From I recently edited

  • Profile Image
    citydogcountrydogtraining
    Asked on March 30, 2017 at 02:35 PM

    This hasn't happened before but thought I would let you know.    When I go in and edit a form and then try to edit another or get submissions from another form it will only open the one I most recently edited.

    For example:   I edited by "Puppy Social Program Registration form"

    When I was finished I tried to open my "Easter Bone Hung Registration form".    I'm clickin on the right form but the only thing that will open is the previously edited "Puppy Social Form".    I tried several of my forms and no matter what form I click on it is the "Puppy social form" that is opening.

    This has happened several times now and the only way out of it is to close the whole brower (closing just the jotform window doesn't do it) and then open the browser again and it's unstuck.

    Mary

  • Profile Image
    david
    Answered on March 30, 2017 at 04:06 PM

    I tried editing a few different forms in your account and was able to switch between editing different forms.  I edited the puppy social program form, navigated back to the My Forms page, then edited the Easter bone hunt form.  The builder switched to the correct form.

    If this is still occurring on your end, let us know what browser you are using and we will see if we can reproduce it in that browser.

  • Profile Image
    iwbrb07
    Answered on March 30, 2017 at 04:23 PM

    Happening to me too. I recorded a screencast but cant submit it.
  • Profile Image
    Nik_C
    Answered on March 30, 2017 at 05:29 PM

    @iwbrb07,

    I opened a separate thread for you and we will attend it here: https://www.jotform.com/answers/1107230

    Thank you!