A field sometimes does not appear on the email notification

  • Profile Image
    johnmaisel
    Asked on April 12, 2017 at 07:38 AM

    I am having a problem with a row not showing on some, not all emails that go out.

    I can not find any conditions that would be prohibiting the row from showing. I do have rows with no data set to hide, but I have confirmed that there is data that should be displayed.

    Here is a link to the form: http://forms.activeagentrealty.com/johnmaisel/contractdates

    The Inspection Period line is the one that is not showing, and it seems to not be showing in the emails that get sent to the Title Company, when Seller is selected.

    Hoping someone can give me an idea of why it's not showing.

    Attaching screens shots of both emails.

  • Profile Image
    candy
    Answered on April 12, 2017 at 08:53 AM

    Hello,

    I've checked your form and cloned it on my side in order to test it.

    As far as I see, the long text area named "Comment for Title Company" in your form is a hidden field with a condition, if "Order Title Search?" field is equal to "Yes", show "Comment for Title Company" in order to let the users fulfill. So, when the users choose "Yes" from the "Order Title Search?" field, they can only enter information to the "Comment for Title Company" area.

    After I have checked your email settings and I have seen that "Hide Empty Fields" option is enabled as seen below:

    All in all, this means if the fields have submitted as empty in the form, they will not be seen in the notification email.

    So, some of your users have chosen "Yes" from the "Order Title Search?" field and they could fulfill the "Comment for Title Company" field. So, when they fulfill you have seen that area in the notification email.

    Some of your users have chosen "No" from the "Order Title Search?" field or they left empty the "Order Title Search?" field and they couldn't see the "Comment for Title Company" field as it is hidden. So, the field could not be seen on the notification email as "Hide Empty Fields" option were enabled. 

    I hope this helps.

    If you need further clarification, let us know.

    Thank you.

  • Profile Image
    johnmaisel
    Answered on April 12, 2017 at 09:44 AM
    Thanks for the reply.
    The Comments for Title Company is working exactly like it should.
    The problem I have having is the Inspection Period not showing up in some
    emails where it should. There should be no conditions on that showing since
    that is filled out in every case.
    Regards,
    John
    John P. Maisel III - REALTOR®
    Broker / Owner / Visionary
    *ACTIVE AGENT REALTY, LLC*
    *654 SE Fort Island Trail*
    *Crystal River, FL 34429*
    Direct – (352) 302-5351
    *Like Us On Facebook!*
    https://www.facebook.com/ActiveAgentRealty
    Want to know more about Citrus County? Click Here

    *Disclaimer: E-mails sent or received shall neither constitute acceptance
    of conducting transactions via electronic means nor create a binding
    contract until and unless a written contract is signed by the parties.*
    ...
  • Profile Image
    david
    Answered on April 12, 2017 at 11:46 AM

    I cloned the form to test it and so far I am unable to reproduce the issue.  I entered the same data as your submission and each email contained all data.  I am not quite sure what is causing that specific field to be empty in some emails.  I will do some more testing to see if I can reproduce this.  If you happen to know under what circumstances the field is not shown in the email, it would be most helpful.