PDF Embedder Widget: Shows loading and nothing happens

  • Profile Image
    ustasc
    Asked on April 20, 2017 at 09:23 AM

    As suggested I've cleared my cache, didn't work. I've tried on my iOS phone and iPad and personal computer at home. I've tried creating a new PDF embedder widget versus editing the current item. I've logged out and had co-workers try from their workstation. Each time the widget opens and it just churns with the 3 dots at the top of the expanded widget menu page. 

    I'm trying to update the 2016 PDF file with a new 2017 file on our website.

    https://www.jotform.com/build/60804866747972 

  • Profile Image
    candy
    Answered on April 20, 2017 at 10:45 AM

    Hello,

    We're really sorry for the inconvenience you have. 

    I have checked your form and also cloned your form named "18 & Over Registration" on my side in order to test it. I have seen the issue with the PDF Embedder Widget as seen below:

    I have removed the widget and added to the form again. This time when uploading a new PDF, it is worked as seen below:

    Please remove the widget and add again, tell us if the issue still persists.

    This issue occurred, because before we were giving the URL of the PDF to the widget. Now, it has changed. We are uploading the PDF to the widget in order to make it view on the form.

    Thank you for your understanding.