What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My custom 'Thank You' message is being cut off

    Asked by jpecommerce on July 19, 2012 at 07:36 PM

    Good afternoon,

     

    I built a custom landing page for one of my form submissions, but it only displays 2 of what should be 5 image links. Specifically, this is what it should look like:

    http://imgur.com/tvlwp

    However, if you press submit at the bottom of the form, you will see that it gets cut off to only show the top two buttons. Here is the link:

    http://www.jphyundai-coquitlam.ca/2013-hyundai-elantra-coquitlam.htm

    Thank you

    Page URL:
    http://www.jphyundai-coquitlam.ca/2013-hyundai-elantra-coquitlam.htm

  • Profile Image
    JotForm Support

    Answered by jonathan on July 19, 2012 at 07:50 PM

    Hi, 

    Can you try using the iframe code embed of the form instead. I am suspecting also that since the form is contained within a div, the dynamic auto-height is causing the thank you page being cut-off.

    Please update us.

    Thanks.

  • Profile Image

    Answered by jpecommerce on July 19, 2012 at 08:06 PM

    OK, so with the iframe code in, the full 'Thank You' message does display. Is it possible for the dynamic auto-height to work within the iframe code embed?

  • Profile Image
    JotForm Support

    Answered by liyam on July 19, 2012 at 08:27 PM

    The auto-height will not work when using the iframe code, this is why it seems to appears to work properly now. 

    I noticed that you have a script in your page that uses jquery.  This may be the reason why the form doesn't appear to work properly when using the javascript code to embed your form.  You can try using the jquery.noConflict() function so that your jquery code will not run in conflict with JotForm's library.

    Thanks.