What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Unable to submit form. It just says please wait..

    Asked by EnhanceHomes on June 05, 2017 at 11:53 AM

    Every time I use this now, the form hangs at the point of submission. My link is: https://goo.gl/rPPl86

    Aury has been looking at this also.



    This is a re-post of a comment on Prepopulating Fields to Your JotForm via URL Parameters

  • Profile Image
    JotForm Support

    Answered by ashwin_d on June 05, 2017 at 03:09 PM

    Hello,

    I'm sorry for the trouble caused to you. 

    I did test your form and I am able to replicate the issue you are having. I am not able to submit your form and it just says "Please wait...". I am reporting it to our backend team. We will get back to you as soon as we have any update form them.

    I have cloned your form and that seems to be work fine. For now, I would suggest you to please test the following cloned form and see if this works as expected:  https://form.jotformpro.com/71556344760964 

    Thank you!

  • Profile Image
    JotForm Support

    Answered by NeilVicente on June 06, 2017 at 08:40 AM

    Hi,

    Your populated form URL has duplicate values on some address fields causing the form scripts to malfunction.

    Please kindly use the following URL instead:

    https://goo.gl/4EWFNx

    Best,

  • Profile Image

    Answered by EnhanceHomes on June 09, 2017 at 01:33 PM

    Thanks for the above, that link works fine.

     

    May I ask however what specifically caused the problem as I regularly will need to pre-populate these forms so need to understand the issue.

     

    Also, are you able to address the fact that the drop down list on page one (address) is not 'remembered' when it is pre-populated?

    Thanks for your help

  • Profile Image
    JotForm Support

    Answered by david on June 09, 2017 at 02:41 PM

    According to the developer assigned "Your populated form URL has duplicate values on some address fields causing the form scripts to malfunction."  To prevent this, make sure the each value is being used only once in the URL.

    As for the address field issue, if you wouldn't mind creating a new thread with the details, we will be happy to have a look.  As far as I can tell though, pre-populating the field you referenced is working:

  • Profile Image

    Answered by EnhanceHomes on June 12, 2017 at 02:11 PM

    Sorry to be a pain but could you please clarify exactly what the duplicate values are?

    "Your populated form URL has duplicate values on some address fields causing the form scripts to malfunction."

     

    Thanks

  • Profile Image
    JotForm Support

    Answered by david on June 12, 2017 at 02:15 PM

    By duplicate values I believe he meant that certain field data was being pre-populated more than once via the URL.  When the duplicate entries were removed from the URL, the form worked as expected.

  • Profile Image
    JotForm Support
  • Profile Image

    Answered by James Dodgson  on June 12, 2017 at 05:20 PM

    im really sorry to keep asking, and thank you for you quick replies, however that doesn't mean anything to me. 

    I would just like to understand how I stop this happening when I prepopulate my form. 

    As it stands I can no longer use Jotform for my forms as the prepopulation doesn't seem to work. 

    Sorry but can you please explain how I avoid this issue when using the normal prepopulation facility (and not hard coding). 

    I should say I am not a developer or IT wiz hence I am not able to understand the earlier coding answer. 

    Thanks for your help. 

  • Profile Image
    JotForm Support

    Answered by david on June 12, 2017 at 05:48 PM

    When creating the URL's, you can't use the same field twice.  In the example above, which was your original URL, you have used

    fullAddress[country]=United%20Kingdom&addressOf[country]=United%20Kingdom

    addressOf64[country]=United%20Kingdom&addressOf66[country]=United%20Kingdom

    Two times in the URL, which is what I highlighted in my example.  If you look at the full URL my colleague gave you, those two parts of the URL are only used once instead of being used twice.

    To prevent this issue in the future, make sure youre URL does not repeat any of the code.  If you try to use fullAddress[country]=United%20Kingdom and then later in the URL fullAddress[country]=United%20Kingdom, that is what is causing the issue. The pre-population works, but only if code is not being repeated.