Date Picker: "Hour" section is not populated at some point when setting is "AM/PM" and default time is "Current"

  • Profile Image
    VolleyballQLD
    Asked on July 03, 2017 at 04:07 AM

    Hi,

     

    My form has suddenly stopped working.  It appears the date field I have, which shows the current date and time is missing some data.  The form is asking the clients to put in a valid time, but the field is read only.

    Since my form is large I have tested this field on a test form and get the same response.  The top five fields are all set to current date and time - read only.

    For now I have turned off the time part of the field on my working form, but this looks like a bug of some kind.

    Thanks

    Jill Kelly

  • Profile Image
    Charlie
    Answered on July 03, 2017 at 05:05 AM

    Apologies for the inconvenience. 

    I was able to replicate the problem, it seems like it is happening when the time format is set to "AM/PM". While if you set it to "24HOUR" it will work fine.

    Here's a test case I made:

    1. Here's my test form: https://form.jotformpro.com/71832176322958.

    2. Here I set up a date field and set the time format to "AM/PM", then set the default time to current. 

     

    3. In preview, the hour section is not being populated. 

     

    4. Now, I changed the time format to "24 hour". 

     

    5. Here the date field will populate the hour section successfully. 

     

    Let me forward this to our developers to have it checked and fixed. Apologies for the inconvenience. 

  • Profile Image
    NeilVicente
    Answered on July 03, 2017 at 05:18 AM

    Hi Jim,

    We're terribly sorry for this inconvenience.

    Today we released a patch that fixes this bug. DateTime and Time pickers should populate correctly from here on out.

    Please let us know if you have further questions or concerns.

    Best,