iPhone camera doesn't work when form is opened from safari app?

  • Profile Image
    Passionio
    Asked on July 07, 2017 at 08:14 AM

    Hello, 

     

    I've created a survey which has video answer submissions through the 'choose file' field. It works fine when the survey is accessed through the facebook app or the google chrome app. Unfortunately when it is opened through an email it default opens in safari and when a 'choose file' section is opened and i try to take a video, both front and back cameras display a black screen and the record function doesn't work. As the majority of the recipients will be receiving the survey through email and completing it from their phone, it its very important that this function works. Please help! 

     

    Thanks!

     

  • Profile Image
    Nik_C
    Answered on July 07, 2017 at 12:12 PM

    I tested this issue on my iPhone in Chrome and Safari, but the camera is opening fine. What I noticed is if you are opening URL in the preview, so not directly in Browser, the issue occurs, but that must be related to permissions for accessing the camera.

    You will notice the preview since it looks like this:

    And you can open it directly in Safari by tapping the bottom right icon.

    So, please try to open the form in the Safari or in Chrome and see if the issue persists.

    We'll wait for your response.

    Thank you!

  • Profile Image
    Passionio
    Answered on July 10, 2017 at 04:28 AM

    I tried opening the link within the Gmail app, it gives me 2 options as i have safari and chrome apps on my iphone. If I opt for chrome it works fine. If i opt for safari it gives me the black screen when I open the camera after tapping 'choose file'. If I then tap on the safari icon in the bottom right, the 'choose file' function doesn't work at all - it doesn't even give me the option to upload from Library or open camera.

    Most users will be receiving the jotform link as an email so will be opening the email in the mail app or gmail app. Is there a way that it will work if they just click on the link and it works directly from there?

    Is there a way the link can be amended to tell the browser to open the link rather than within the email app?  

    As soon as the users have to do anything like copy/pasting the link elsewhere and completing the form, most of them will drop out and not want to complete the survey - It has to be as simple as possible for the user.

    Thanks again!

  • Profile Image
    liyam
    Answered on July 10, 2017 at 06:57 AM

    Coming from your explanation that it works well with Chrome but not with Safari, this may be an issue with your app permissions. Can you check your Safari browser app settings if you have the camera access allowed?

    You can go to Settings > Privacy > Camera. find the app you want to allow camera access to, and switch it so that the switch is green.

    Thanks.

  • Profile Image
    Passionio
    Answered on July 10, 2017 at 07:19 AM

    All of my apps in the list are set on green for camera access. Interestingly, Safari isn't on the list.

    My friend said that this might be an iOS issue with trying to open apps within apps on older phones. But i have the 6s and the latest iOS update so i don't understand why it isn't working for me.

     

    Thanks

  • Profile Image
    Nik_C
    Answered on July 10, 2017 at 10:57 AM

    I tested this issue on my iPhone 7 with the latest iOS update, but I wasn't able to replicate this issue, the camera is opening immediately.

    Please try hard restart of your iPhone, to do so press and hold the power button and home button(if the home button is not mechanical then hold the power button and volume down) until you see the Apple logo.

    That will restart your phone (but it will not remove everything).

    Please try and let us know if it worked.

    Thank you!

  • Profile Image
    Passionio
    Answered on July 11, 2017 at 03:21 AM

    Yeah I tried all of the usual troubleshooting steps before seeking any help! Its still having this same issue. If I cant have it working for all users then I won't be able to use jotform for this which is a shame as I thought i'd found the perfect solution. :(

     

    Thanks 

  • Profile Image
    Nik_C
    Answered on July 11, 2017 at 04:36 AM

    Unfortunately, I wouldn't say it is related to JotForm, that is something that is handled by iOS, and I wasn't able to replicate this issue since the camera opens normally.

    I made this simple form https://form.jotformpro.com/71874356059971 with two different upload fields, both worked for me fine. 

    Please try what happens on your phone.

    We'll wait for your response.

    Thank you!