After filling in the form on my website (wordpress.com) and press the submit, it shows "Please wait" and just stops there.

  • Profile Image
    nawawn
    Asked on July 19, 2017 at 09:29 AM

    The form works great when I tried it at the Preview Form mode on your website. I received the form in my email. But for some reasons, it is not working on my website. Jotform is unbelievably easy to use and if it works for my website, I will be subscribing to the paid version in no time. Any advice would be much appreciated! 

  • Profile Image
    Kiran
    Answered on July 19, 2017 at 12:36 PM

    It looks like there is a conflict with the scripts on the web page. How did you embed the form on your web page? Could you try embedding the form by following the steps in the guide below:

    https://www.jotform.com/help/299-How-to-embed-a-form-to-Wordpress-com

    Please get back to us if the issue still persists. We will be happy to assist you further. 

  • Profile Image
    nawawn
    Answered on July 20, 2017 at 04:20 AM

    Hi Kiran, 

    Thank you for getting back to me so quickly. I tried the exact steps as mentioned. These are quite simple steps, so I believe I would not have got it wrong. 

    After filling in the form and pressed the submit button, the submit botton just keeps showing "Please wait..". 

    If you could please let me know any other ways that could work, I would much appreciate it. 

    Many thanks, 

    Patrick

  • Profile Image
    Kiran
    Answered on July 20, 2017 at 06:58 AM

    I have tried embedding the same form on my test WordPress website and see that it is working fine at my end. It seems that the issue is related to the theme or specific page. Could you try adding a new page and try adding the form? If it is possible, please try using a different theme to test if the embedded form is working.

    Let us know how it goes.