URGENT - Skip to a Page conditions isn't working

  • Profile Image
    kjulius
    Asked on August 03, 2017 at 12:37 PM

    On multiple forms, the Skip to a Page condition does not appear to be working. When Next is selected and input is valid, the next page does not show. A Back button also is not visible on the form, even though it is set to display in the properties. We have more than 50 forms where this has just started. 

  • Profile Image
    Chriistian
    Answered on August 03, 2017 at 01:49 PM

    I just tested and the Next and Back buttons are properly working. I was also able to submit your form without problem.

     

    What browser and device are you using to submit the form?

  • Profile Image
    kjulius
    Answered on August 03, 2017 at 01:52 PM

    It appears this is happening intermittently now. Forms are working again, but some users are reporting later that this functionality has stopped. Is it possible there could be latency issues?

     

    https://www.jotform.com/kjulius/decatur-mattoon-product-layout

     

    Using Chrome browser in three test cases on three different machines. Ctrl+Refresh seems to clear whatever may be stored in the cache that is preventing it, but not in all cases

  • Profile Image
    Chriistian
    Answered on August 03, 2017 at 03:38 PM

    I check the set up of your form and I noticed the following:

    1. The condition setup for the Skip page might be conflicting. The condition IF New Edition, Revise, or Commercial? IS EQUAL TO "Revise" SKIP TO Page 3 by default will also execute the condition IF New Edition, Revise, or Commercial? IS EQUAL TO "Revise" SKIP TO Page 2. There's no need to add this condition on the form.

    Please try to disable/delete the condition IF New Edition, Revise, or Commercial? IS EQUAL TO "Revise" SKIP TO Page 2 and see if this will help.

    2. There are some errors on your conditions that might be causing the issue. Please try to fix the condition or remove them and see if this will help.

    3. For the Back button that is not visible, I noticed that you have added a condition to Hide the Page Break on Page 2 when the New Edition, Revise, or Commercial? field is FILLED.

    If you want the Page Break (Back Button) to be displayed, please remove the condition.