[submit.jotform.us] Error on Thank You Page - Internet Explorer and Firefox on PC

  • Profile Image
    nmss
    Asked on August 04, 2017 at 02:33 PM

    User's are reporting an error with the Thank You page with IE and Firefox on PC but it works on Chrome.

    Please see screenshot. The form URL is:  https://form.jotform.com/nmss/email

    Any ideas on how to remedy this?

    Thanks, 

    John

  • Profile Image
    Mike
    Answered on August 04, 2017 at 03:51 PM

    We have reported the issue to our Backend Team. Some users might be having access issue to our .us domain. Could you please try the next links to see if they are working for you?

    https://www.jotform.us

    https://submit.jotform.us

    If there are any errors, please let us know.

  • Profile Image
    nmss
    Answered on August 04, 2017 at 04:44 PM
    We are getting mixed results from my team with the links. They are working for some and not for others. Did you recently start using the .us domain? If so, when did you switch over? I also have our network team checking to see if anything has changed on our network but so far I have not heard of any network changes.
    Here is the feedback from my team from the last hour:
    "Both worked for me in Chrome. However, the submit.jotform.us link led to a "The proxy server is refusing connections" page in Firefox. I'm on a PC on the VPN."
    "I tried the https://submit.jotform.us link again just to be sure, and this time it worked in Chrome but failed in IE and Firefox. Now I'm not sure if I actually tried that link before or just the https://www.jotform.us link, which works fine in all 3 browsers."
    "I just tried IE and had the same experience as Peter: https://www.jotform.us works in Chrome, Firefox, and IE. https://submit.jotform.us works in Chrome but not Firefox or IE."
    Do you have any other recommendations to troubleshoot this?
    John
    ________________________________
    ...
  • Profile Image
    nmss
    Answered on August 04, 2017 at 05:43 PM
    FYI, we had our IT team add the URLs to our global network whitelist and that appears to have resolved the issue.
    Thank you for the prompt response you may close the support ticket.
    John
    ________________________________
    ...