Why submit button is not working?

  • Profile Image
    Starfeather19
    Asked on August 18, 2017 at 04:21 PM

    I am using GoDaddy and wordpress. For some reason, I can take my embedded code and use it on my page. It shows up perfectly fine. But when you fill out the form and hit submit it just keeps saying "please wait". It does nothing else after that. 

    I tried the Iframe stuff, but none of that works. Need help. 

  • Profile Image
    BDAVID
    Answered on August 18, 2017 at 04:38 PM

    Please remove your form, and embed this Iframe code instead:

     <iframe id="JotFormIFrame-72294146548160" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.us/72294146548160" frameborder="0" style="width:100%; height:539px; border:none;" scrolling="no"> </iframe>

  • Profile Image
    Starfeather19
    Answered on August 18, 2017 at 04:40 PM

    Tried! It doesn't work. 

  • Profile Image
    BDAVID
    Answered on August 18, 2017 at 04:43 PM

    Your form works fine, we just submitted a test from your form's direct link and it went through just fine. I have inspected the URL of your page, and it does not have the Iframe code I just provided. Could you please remove your form, and paste the code I just provided? If it does not work, do not remove, get back to us, and let us know, so we can test it.

  • Profile Image
    Starfeather19
    Answered on August 18, 2017 at 06:43 PM
    I just did and I get the code view on my page, no form.
    Sent from my iPhone
    ...
  • Profile Image
    Jan
    Answered on August 18, 2017 at 09:30 PM

    Please try to insert the iFrame code in the "Text / HTML" tab of the Post/Page editor. Here's a screenshot:

    Related guide: https://www.jotform.com/help/4-Adding-Forms-to-Wordpress-org-Version.

    Hope that helps. Thank you.

  • Profile Image
    Starfeather19
    Answered on August 19, 2017 at 12:43 AM
    That worked but only half the form will show up/no scrolling option.
    Sent from my iPhone
    ...
  • Profile Image
    Nik_C
    Answered on August 19, 2017 at 04:06 AM

    Replace the code with this one:

     <iframe id="JotFormIFrame-72294146548160" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.us/72294146548160" frameborder="0" style="width:100%; height:1020px; border:none;" scrolling="yes"> </iframe>

    I adjusted the height and enabled scrolling.

    Please let us know how it worked.

    Thank you!

  • Profile Image
    Starfeather19
    Answered on August 19, 2017 at 11:43 AM
    I changed scrolling to yes.. Thanks so much for your help! Everything is
    working great!
    ...