Conditional Logic [Require Field]: It does not un-require uploads field if multiple files option is enabled.

  • Profile Image
    eaglelibrarytech
    Asked on August 23, 2017 at 06:24 PM

    Hello,

    I recently updated a form to allow a multiple file submission button. For some reason the condition to un-require the multiple file submission field when the field above it is filled, isn't working. If you populate the field above it the * goes away and all looks well but when you go to submit it says that field is required. But if the multiple file submission field is populated with at least 1 file, the field aboves condition works and becomes un-required and submits properly.

     

    I have attached screenshots.

  • Profile Image
    Kevin_G
    Answered on August 23, 2017 at 09:51 PM

    Thank you for your report. 

    I have tested this on my end and was able to replicate the same issue. I will report it to our second level, in the meantime I would recommend you to handle the required property with conditions, I mean, disable it from your field settings and require/un-require the field with conditions. 

    We will let you know as soon as we receive any update about it. 

     

  • Profile Image
    eaglelibrarytech
    Answered on August 23, 2017 at 10:03 PM

    Kevin_G,

    That is how it is setup right now in a non-working state. The fields do not require it but only the conditions do. 

    As of now my fix to make this form usable is going to be disabling the conditions for both fields till this is fixed.

  • Profile Image
    NeilVicente
    Answered on September 07, 2017 at 03:38 PM

    Hi,

    This issue is now resolved.

    Unrequire condition now works for multi-file upload fields.

    Cheers!

  • Profile Image
    eaglelibrarytech
    Answered on September 11, 2017 at 09:21 PM

    After testing today, this is still not fixed. Attached are my screenshots of my exact configuration. First test was with both fields required by default with conditions enable. Second test was with both fields NOT required by default with condition turned on. Neither worked.

     

  • Profile Image
    Jan
    Answered on September 11, 2017 at 10:30 PM

    Unfortunately, I was not able to replicate the issue on a cloned form. First, I enabled these 3 conditions that are currently disabled.

    After that, I tested the URL field and upload field. If I upload a file, the URL field will not be required. If I put a URL, the file upload will not be required.

    Please try to enable the conditions and verify if it will work or not. If the issue is still the same, please "unrequire" the File Upload field. Just right click it and then choose the "Unrequire" option.

    Hope that helps. Thank you.

  • Profile Image
    eaglelibrarytech
    Answered on September 12, 2017 at 12:11 PM

    Jan thank you for the quick reply. Unfortunately, I wasn't able to have the same luck as you. I got rid of those 3 old fields and the conditions tied to them because they were obsolete now. In the gif you attached I get the same result, but when I go to submit is when it denys the submission and says the multi-file upload is blank and is required. Did you submit on any of your attempts?

    Just so there is no confusion. Neither of my fields are required in the "Build" section of the form by default. All I have is the 2 un-require conditions. The "this field is required" prompt doesn't show up till I hit submit. 

  • Profile Image
    Nik_C
    Answered on September 12, 2017 at 01:04 PM

    I temporarily re-activated requiring conditions:

    So I could test your form and I was able to replicate this issue, the form is not submittable:

    The field is required even though it was conditionally unrequired.

    I will consult the developer assigned regarding this issue.

    Thank you for your patience.

  • Profile Image
    NeilVicente
    Answered on September 13, 2017 at 10:37 AM

    Hi there,

    It should be working now. Can you please check and let us know?

  • Profile Image
    eaglelibrarytech
    Answered on September 13, 2017 at 11:46 AM

    Looks good! Thank you all for the support.